Skip to content

Commit 726a8b9

Browse files
committed
Merge commit 'v0.9.0-169-g5c945e1' into debian
* commit 'v0.9.0-169-g5c945e1': BUG: fill_value not being applied for mixed type frame pandas-dev#2191 BUG: bug in setup.py with cython and sdist command class pandas-dev#2188 BLD: c scope decl wrong
2 parents b159fc1 + 5c945e1 commit 726a8b9

File tree

4 files changed

+13
-7
lines changed

4 files changed

+13
-7
lines changed

pandas/core/frame.py

+1-1
Original file line numberDiff line numberDiff line change
@@ -3320,7 +3320,7 @@ def _arith_op(left, right):
33203320
# XXX no good for duplicate columns
33213321
result = {}
33223322
for col in this:
3323-
result[col] = func(this[col].values, other[col].values)
3323+
result[col] = _arith_op(this[col].values, other[col].values)
33243324
else:
33253325
result = _arith_op(this.values, other.values)
33263326

pandas/src/numpy_helper.h

+3-2
Original file line numberDiff line numberDiff line change
@@ -136,7 +136,8 @@ char_to_string(char* data) {
136136
#include <errno.h>
137137
#include <float.h>
138138

139-
double PANDAS_INLINE xstrtod(const char *p, char **q, char decimal, char sci, int skip_trailing);
139+
PANDAS_INLINE double
140+
xstrtod(const char *p, char **q, char decimal, char sci, int skip_trailing);
140141

141142
int to_double(char *item, double *p_value, char sci, char decimal)
142143
{
@@ -250,7 +251,7 @@ PANDAS_INLINE void uppercase(char *p) {
250251
}
251252

252253

253-
double PANDAS_INLINE xstrtod(const char *str, char **endptr, char decimal,
254+
PANDAS_INLINE double xstrtod(const char *str, char **endptr, char decimal,
254255
char sci, int skip_trailing)
255256
{
256257
double number;

pandas/tests/test_frame.py

+7
Original file line numberDiff line numberDiff line change
@@ -6086,6 +6086,13 @@ def test_combineAdd(self):
60866086
comb = df1.combineAdd(df2)
60876087
assert_frame_equal(comb, df3)
60886088

6089+
# mixed type GH2191
6090+
df1 = DataFrame({'A' : [1, 2], 'B' : [3, 4]})
6091+
df2 = DataFrame({'A' : [1, 2], 'C' : [5, 6]})
6092+
rs = df1.combineAdd(df2)
6093+
xp = DataFrame({'A' : [2, 4], 'B' : [3, 4.], 'C' : [5, 6.]})
6094+
assert_frame_equal(xp, rs)
6095+
60896096
# TODO: test integer fill corner?
60906097

60916098
def test_combineMult(self):

setup.py

+2-4
Original file line numberDiff line numberDiff line change
@@ -538,14 +538,12 @@ def run(self):
538538
cmdclass['build_ext'] = build_ext
539539
if BUILD_CACHE_DIR: # use the cache
540540
cmdclass['build_ext'] = CachingBuildExt
541+
cmdclass['cython'] = CythonCommand
542+
cmdclass['sdist'] = CheckSDist
541543
else:
542-
543544
suffix = '.c'
544545
cmdclass['build_src'] = DummyBuildSrc
545-
546-
cmdclass['cython'] = CythonCommand
547546
cmdclass['build_ext'] = build_ext
548-
cmdclass['sdist'] = CheckSDist
549547

550548
tseries_depends = ['reindex', 'groupby', 'skiplist', 'moments',
551549
'reduce', 'stats', 'datetime',

0 commit comments

Comments
 (0)