File tree 1 file changed +5
-4
lines changed
1 file changed +5
-4
lines changed Original file line number Diff line number Diff line change @@ -20,8 +20,10 @@ EXCLUDE_MORETESTS :=
20
20
: # Explicit build system to avoid use of all-in-1 Makefile
21
21
dh $@ --buildsystem=python_distutils
22
22
23
- cythonize :
24
- find pandas/src -iname * .c -delete
23
+ clean_generated :
24
+ grep -l -e ' Generated by Cython' pandas/src/* .c | xargs -r rm -f
25
+
26
+ cythonize : clean_generated
25
27
python setup.py cython
26
28
cp pandas/src/* .c debian/cythonized-files
27
29
echo " $( UVER) " > | debian/cythonized-files/VERSION
@@ -32,11 +34,10 @@ override_dh_auto_configure:
32
34
cp -rp debian/cythonized-files/* .c pandas/src/; } || :
33
35
dh_auto_configure
34
36
35
- override_dh_clean :
37
+ override_dh_clean : clean_generated
36
38
: # Make sure that cythonized sources are up-to-date
37
39
[ " $( UVER) " = " ` cat debian/cythonized-files/VERSION` " ]
38
40
rm -rf build doc/_build * -stamp # pandas.egg-info pandas/datasets/__config__.py
39
- grep -l -e ' Generated by Cython' pandas/src/* .c | xargs -r rm -f
40
41
dh_clean
41
42
: # prune auto-generated version.py -- will be generated during build again
42
43
rm -f pandas/version.py
You can’t perform that action at this time.
0 commit comments