Skip to content

Commit dcc1ca8

Browse files
committed
pypi-pytest_asyncio: Autospec creation for update from version 0.16.0 to version 0.17.0
Andrew Svetlov (20): Add 'Framework :: Asyncio' trove classifier Reformat with black Fix readme, the plugin now provide fixtures for unused udp ports also (#241) Ignote .python-version file marker Update changelog for added plugin modes (#243) Avoid non-stantdard approached for warning emitting (#242) Rewrite flaky integration test (#246) Setup pre-commit hooks and reformat code (#245) Setup initial codeowners (#244) Switch to declarative setup (#247) Fix typo Configure dependabot version updater (#250) Setup GitHub Workflows linter and yaml-reformatter (#253) Release process automation (#252) Build on tag Fix trove classifier for asyncio Fix release artifacts Convert README.rst to Markdown for making githun release Fix pandoc installation procedure Bump to 0.17 release Bruno Oliveira (2): Add note about unittest.TestCase not being supported Mention IsolatedAsyncioTestCase Dominik S. Buse (1): Add unused port helpers for UDP (#99) Imran Hayder (1): Switch to setuptools-scm for versioning (#37) Kian-Meng, Ang (1): Fix typo Michael Seifert (7): Teardown of the event_loop fixture no longer replaces the event loop policy. refactor: Removed use of obsolete transfer_markers during test collection phase. feat!: Drop support for Python 3.6. refactor: Moved test_hypothesis_integration to "hypothesis" subfolder and renamed it to "test_base". fix: Fixed double wrapping of inherited Hypothesis tests. doc: Updated docstring of pytest_pyfunc_call. doc: Mentioned additional test dependency on flaky in the changelog. Nikita Sobolev (1): Use `[email protected]` in CI Piper Merriam (1): Add mechanism for explicit marking of fixtures which should be run with asyncio (#125) Tin Tvrtkovic (2): Update CI badge Durr dependabot[bot] (1): Bump codecov/codecov-action from 1 to 2.1.0 (#251) kriek (1): Fixes pytest-dev/pytest-asyncio#219 (#221) wjsi (1): Support flaky on async tests
1 parent 85d0399 commit dcc1ca8

File tree

6 files changed

+25
-20
lines changed

6 files changed

+25
-20
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-pytest_asyncio
2-
URL = https://files.pythonhosted.org/packages/89/53/8844d99d5343eecbb6d740d708581fbf63cefd560c07c7164b12691e54eb/pytest-asyncio-0.16.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/3e/ed/ebeda980c5b22164ed85a2540acaaa3203ce02d5cd7ec956757a65574b39/pytest-asyncio-0.17.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-pytest_asyncio
3-
url = https://files.pythonhosted.org/packages/89/53/8844d99d5343eecbb6d740d708581fbf63cefd560c07c7164b12691e54eb/pytest-asyncio-0.16.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/3e/ed/ebeda980c5b22164ed85a2540acaaa3203ce02d5cd7ec956757a65574b39/pytest-asyncio-0.17.0.tar.gz
44
archives =
55
giturl = https://github.com/pytest-dev/pytest-asyncio.git
66
domain =

pypi-pytest_asyncio.spec

+20-15
Original file line numberDiff line numberDiff line change
@@ -3,21 +3,26 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-pytest_asyncio
6-
Version : 0.16.0
7-
Release : 30
8-
URL : https://files.pythonhosted.org/packages/89/53/8844d99d5343eecbb6d740d708581fbf63cefd560c07c7164b12691e54eb/pytest-asyncio-0.16.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/89/53/8844d99d5343eecbb6d740d708581fbf63cefd560c07c7164b12691e54eb/pytest-asyncio-0.16.0.tar.gz
10-
Summary : Pytest support for asyncio.
6+
Version : 0.17.0
7+
Release : 31
8+
URL : https://files.pythonhosted.org/packages/3e/ed/ebeda980c5b22164ed85a2540acaaa3203ce02d5cd7ec956757a65574b39/pytest-asyncio-0.17.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/3e/ed/ebeda980c5b22164ed85a2540acaaa3203ce02d5cd7ec956757a65574b39/pytest-asyncio-0.17.0.tar.gz
10+
Summary : Pytest support for asyncio
1111
Group : Development/Tools
1212
License : Apache-2.0
1313
Requires: pypi-pytest_asyncio-license = %{version}-%{release}
1414
Requires: pypi-pytest_asyncio-python = %{version}-%{release}
1515
Requires: pypi-pytest_asyncio-python3 = %{version}-%{release}
1616
BuildRequires : buildreq-distutils3
17-
Provides: pytest-asyncio
18-
Provides: pytest-asyncio-python
19-
Provides: pytest-asyncio-python3
17+
BuildRequires : pypi(py)
2018
BuildRequires : pypi(pytest)
19+
BuildRequires : pypi(setuptools)
20+
BuildRequires : pypi(setuptools_scm)
21+
BuildRequires : pypi(wheel)
22+
BuildRequires : pypi-pluggy
23+
BuildRequires : pypi-pytest
24+
BuildRequires : pypi-tox
25+
BuildRequires : pypi-virtualenv
2126

2227
%description
2328
pytest-asyncio: pytest support for asyncio
@@ -52,29 +57,29 @@ python3 components for the pypi-pytest_asyncio package.
5257

5358

5459
%prep
55-
%setup -q -n pytest-asyncio-0.16.0
56-
cd %{_builddir}/pytest-asyncio-0.16.0
60+
%setup -q -n pytest-asyncio-0.17.0
61+
cd %{_builddir}/pytest-asyncio-0.17.0
5762

5863
%build
5964
export http_proxy=http://127.0.0.1:9/
6065
export https_proxy=http://127.0.0.1:9/
6166
export no_proxy=localhost,127.0.0.1,0.0.0.0
6267
export LANG=C.UTF-8
63-
export SOURCE_DATE_EPOCH=1641480263
68+
export SOURCE_DATE_EPOCH=1642089205
6469
export GCC_IGNORE_WERROR=1
6570
export CFLAGS="$CFLAGS -fno-lto "
6671
export FCFLAGS="$FFLAGS -fno-lto "
6772
export FFLAGS="$FFLAGS -fno-lto "
6873
export CXXFLAGS="$CXXFLAGS -fno-lto "
6974
export MAKEFLAGS=%{?_smp_mflags}
70-
python3 setup.py build
75+
python3 -m build --wheel --skip-dependency-check --no-isolation
7176

7277
%install
7378
export MAKEFLAGS=%{?_smp_mflags}
7479
rm -rf %{buildroot}
7580
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-pytest_asyncio
76-
cp %{_builddir}/pytest-asyncio-0.16.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pytest_asyncio/c700a8b9312d24bdc57570f7d6a131cf63d89016
77-
python3 -tt setup.py build install --root=%{buildroot}
81+
cp %{_builddir}/pytest-asyncio-0.17.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pytest_asyncio/92a74693f02c8e78dd90b2014c52bc35a95bab86
82+
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
7883
echo ----[ mark ]----
7984
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
8085
echo ----[ mark ]----
@@ -84,7 +89,7 @@ echo ----[ mark ]----
8489

8590
%files license
8691
%defattr(0644,root,root,0755)
87-
/usr/share/package-licenses/pypi-pytest_asyncio/c700a8b9312d24bdc57570f7d6a131cf63d89016
92+
/usr/share/package-licenses/pypi-pytest_asyncio/92a74693f02c8e78dd90b2014c52bc35a95bab86
8893

8994
%files python
9095
%defattr(-,root,root,-)

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
30
1+
31

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
e536f9ed5e67bc2a17e646d20f5fa0dce162f3cd/pytest-asyncio-0.16.0.tar.gz
1+
dd6054314b4080364f876812558cdc1189db60ff/pytest-asyncio-0.17.0.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
0.16.0
1+
0.17.0

0 commit comments

Comments
 (0)