Skip to content

Commit 85d0399

Browse files
committed
Rename from pytest-asyncio to pypi-pytest_asyncio
0 parents  commit 85d0399

16 files changed

+207
-0
lines changed

.gitignore

+19
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,19 @@
1+
.*~
2+
*~
3+
*.info
4+
*.mod
5+
*.swp
6+
.repo-index
7+
*.log
8+
build.log.round*
9+
*.tar.*
10+
*.tgz
11+
!*.tar.*.*
12+
*.zip
13+
*.jar
14+
*.pom
15+
*.xml
16+
commitmsg
17+
results/
18+
rpms/
19+
for-review.txt

Makefile

+5
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,5 @@
1+
PKG_NAME := pypi-pytest_asyncio
2+
URL = https://files.pythonhosted.org/packages/89/53/8844d99d5343eecbb6d740d708581fbf63cefd560c07c7164b12691e54eb/pytest-asyncio-0.16.0.tar.gz
3+
ARCHIVES =
4+
5+
include ../common/Makefile.common

buildreq_add

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains additional build requirements that did not get
2+
# picked up automatically. One name per line, no whitespace.

buildreq_ban

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains build requirements that get picked up but are
2+
# undesirable. One entry per line, no whitespace.

excludes

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains the output files that need %exclude. Full path
2+
# names, one per line.

options.conf

+66
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,66 @@
1+
[package]
2+
name = pypi-pytest_asyncio
3+
url = https://files.pythonhosted.org/packages/89/53/8844d99d5343eecbb6d740d708581fbf63cefd560c07c7164b12691e54eb/pytest-asyncio-0.16.0.tar.gz
4+
archives =
5+
giturl = https://github.com/pytest-dev/pytest-asyncio.git
6+
domain =
7+
alias =
8+
9+
[autospec]
10+
# build 32 bit libraries
11+
32bit = false
12+
# allow package to build with test failures
13+
allow_test_failures = false
14+
# unset %build ld_as_needed variable
15+
asneeded = false
16+
# this package is trusted enough to automatically update (used by other tools)
17+
autoupdate = true
18+
# extend flags with '-std=gnu++98
19+
broken_c++ = false
20+
# disable parallelization during build
21+
broken_parallel_build = false
22+
# this package is a library compatibility package and only ships versioned library files
23+
compat = false
24+
# set conservative build flags
25+
conservative_flags = false
26+
# dev package requires the extras to be installed
27+
dev_requires_extras = false
28+
# pass -ffast-math to compiler
29+
fast-math = false
30+
# optimize build for speed over size
31+
funroll-loops = false
32+
# set flags to smallest -02 flags possible
33+
insecure_build = false
34+
# do not remove static libraries
35+
keepstatic = false
36+
# do not require autostart subpackage
37+
no_autostart = false
38+
# do not generate debuginfo for this package
39+
nodebug = false
40+
# disable stripping binaries
41+
nostrip = false
42+
# configure build also for openmpi
43+
openmpi = false
44+
# optimize build for size over speed
45+
optimize_size = false
46+
# set profile for pgo
47+
pgo = false
48+
# set flags for security-sensitive builds
49+
security_sensitive = false
50+
# package is only used by servers
51+
server = false
52+
# do not run test suite
53+
skip_tests = false
54+
# add .so files to the lib package instead of dev
55+
so_to_lib = false
56+
# configure build for avx2
57+
use_avx2 = false
58+
# configure build for avx512
59+
use_avx512 = false
60+
# add clang flags
61+
use_clang = false
62+
# configure build for lto
63+
use_lto = false
64+
# require package verification for build
65+
verify_required = false
66+

pkgconfig_add

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains additional pkgconfig build requirements that did
2+
# not get picked up automatically. One name per line, no whitespace.

pkgconfig_ban

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains pkgconfig build requirements that get picked up
2+
# but are undesirable. One entry per line, no whitespace.

pypi-pytest_asyncio.spec

+94
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,94 @@
1+
#
2+
# This file is auto-generated. DO NOT EDIT
3+
# Generated by: autospec.py
4+
#
5+
Name : pypi-pytest_asyncio
6+
Version : 0.16.0
7+
Release : 30
8+
URL : https://files.pythonhosted.org/packages/89/53/8844d99d5343eecbb6d740d708581fbf63cefd560c07c7164b12691e54eb/pytest-asyncio-0.16.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/89/53/8844d99d5343eecbb6d740d708581fbf63cefd560c07c7164b12691e54eb/pytest-asyncio-0.16.0.tar.gz
10+
Summary : Pytest support for asyncio.
11+
Group : Development/Tools
12+
License : Apache-2.0
13+
Requires: pypi-pytest_asyncio-license = %{version}-%{release}
14+
Requires: pypi-pytest_asyncio-python = %{version}-%{release}
15+
Requires: pypi-pytest_asyncio-python3 = %{version}-%{release}
16+
BuildRequires : buildreq-distutils3
17+
Provides: pytest-asyncio
18+
Provides: pytest-asyncio-python
19+
Provides: pytest-asyncio-python3
20+
BuildRequires : pypi(pytest)
21+
22+
%description
23+
pytest-asyncio: pytest support for asyncio
24+
==========================================
25+
26+
%package license
27+
Summary: license components for the pypi-pytest_asyncio package.
28+
Group: Default
29+
30+
%description license
31+
license components for the pypi-pytest_asyncio package.
32+
33+
34+
%package python
35+
Summary: python components for the pypi-pytest_asyncio package.
36+
Group: Default
37+
Requires: pypi-pytest_asyncio-python3 = %{version}-%{release}
38+
39+
%description python
40+
python components for the pypi-pytest_asyncio package.
41+
42+
43+
%package python3
44+
Summary: python3 components for the pypi-pytest_asyncio package.
45+
Group: Default
46+
Requires: python3-core
47+
Provides: pypi(pytest_asyncio)
48+
Requires: pypi(pytest)
49+
50+
%description python3
51+
python3 components for the pypi-pytest_asyncio package.
52+
53+
54+
%prep
55+
%setup -q -n pytest-asyncio-0.16.0
56+
cd %{_builddir}/pytest-asyncio-0.16.0
57+
58+
%build
59+
export http_proxy=http://127.0.0.1:9/
60+
export https_proxy=http://127.0.0.1:9/
61+
export no_proxy=localhost,127.0.0.1,0.0.0.0
62+
export LANG=C.UTF-8
63+
export SOURCE_DATE_EPOCH=1641480263
64+
export GCC_IGNORE_WERROR=1
65+
export CFLAGS="$CFLAGS -fno-lto "
66+
export FCFLAGS="$FFLAGS -fno-lto "
67+
export FFLAGS="$FFLAGS -fno-lto "
68+
export CXXFLAGS="$CXXFLAGS -fno-lto "
69+
export MAKEFLAGS=%{?_smp_mflags}
70+
python3 setup.py build
71+
72+
%install
73+
export MAKEFLAGS=%{?_smp_mflags}
74+
rm -rf %{buildroot}
75+
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-pytest_asyncio
76+
cp %{_builddir}/pytest-asyncio-0.16.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pytest_asyncio/c700a8b9312d24bdc57570f7d6a131cf63d89016
77+
python3 -tt setup.py build install --root=%{buildroot}
78+
echo ----[ mark ]----
79+
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
80+
echo ----[ mark ]----
81+
82+
%files
83+
%defattr(-,root,root,-)
84+
85+
%files license
86+
%defattr(0644,root,root,0755)
87+
/usr/share/package-licenses/pypi-pytest_asyncio/c700a8b9312d24bdc57570f7d6a131cf63d89016
88+
89+
%files python
90+
%defattr(-,root,root,-)
91+
92+
%files python3
93+
%defattr(-,root,root,-)
94+
/usr/lib/python3*/*

release

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
30

requires_add

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains additional runtime requirements that did not get
2+
# picked up automatically. One name per line, no whitespace.

requires_ban

+2
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,2 @@
1+
# This file contains runtime requirements that get picked up but are
2+
# undesirable. One entry per line, no whitespace.

testresults

+5
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,5 @@
1+
Total : 0
2+
Pass : 0
3+
Fail : 0
4+
Skip : 0
5+
XFail : 0

upstream

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
e536f9ed5e67bc2a17e646d20f5fa0dce162f3cd/pytest-asyncio-0.16.0.tar.gz

versions

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
0.16.0

whatrequires

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
# This file contains recursive sources that require this package

0 commit comments

Comments
 (0)