Skip to content

Commit ff35c3d

Browse files
Debian Science Teamrebecca-palmer
Debian Science Team
authored andcommitted
Stop using pkg_resources
Author: Rebecca N. Palmer <[email protected]> Bug-Debian: https://bugs.debian.org/1083523 Forwarded: no, it would crash on Macs Gbp-Pq: Name no_pkg_resources.patch
1 parent 62d318c commit ff35c3d

File tree

1 file changed

+1
-2
lines changed

1 file changed

+1
-2
lines changed

setup.py

+1-2
Original file line numberDiff line numberDiff line change
@@ -16,7 +16,6 @@
1616
from sysconfig import get_config_vars
1717

1818
import numpy
19-
from pkg_resources import parse_version
2019
from setuptools import (
2120
Command,
2221
Extension,
@@ -46,7 +45,7 @@ def is_platform_mac():
4645
)
4746
from Cython.Build import cythonize
4847

49-
_CYTHON_INSTALLED = parse_version(_CYTHON_VERSION) >= parse_version(min_cython_ver)
48+
_CYTHON_INSTALLED = True
5049
except ImportError:
5150
_CYTHON_VERSION = None
5251
_CYTHON_INSTALLED = False

0 commit comments

Comments
 (0)