Skip to content

Commit 972ffb8

Browse files
Debian Science Teamrebecca-palmer
Debian Science Team
authored andcommitted
skip_tests_copyright
and revert accidental change to _version.py Author: Rebecca N. Palmer <[email protected]> Forwarded: no Gbp-Pq: Name skip_tests_copyright.patch
1 parent 645aeb5 commit 972ffb8

File tree

2 files changed

+6
-2
lines changed

2 files changed

+6
-2
lines changed

pandas/_version.py

+2-2
Original file line numberDiff line numberDiff line change
@@ -20,8 +20,8 @@ def get_keywords():
2020
# setup.py/versioneer.py will grep for the variable names, so they must
2121
# each be defined on a line of their own. _version.py will just call
2222
# get_keywords().
23-
git_refnames = " (tag: v0.23.3)"
24-
git_full = "edb71fda022c6a155717e7a25679040ee0476639"
23+
git_refnames = "$Format:%d$"
24+
git_full = "$Format:%H$"
2525
keywords = {"refnames": git_refnames, "full": git_full}
2626
return keywords
2727

pandas/tests/io/test_html.py

+4
Original file line numberDiff line numberDiff line change
@@ -365,6 +365,7 @@ def test_python_docs_table(self):
365365
assert sorted(zz) == sorted(['Repo', 'What'])
366366

367367
@pytest.mark.slow
368+
@pytest.mark.skip(reason='test data removed for copyright reasons')
368369
def test_thousands_macau_stats(self, datapath):
369370
all_non_nan_table_index = -2
370371
macau_data = datapath("io", "data", "macau.html")
@@ -375,6 +376,7 @@ def test_thousands_macau_stats(self, datapath):
375376
assert not any(s.isna().any() for _, s in df.iteritems())
376377

377378
@pytest.mark.slow
379+
@pytest.mark.skip(reason='test data removed for copyright reasons')
378380
def test_thousands_macau_index_col(self, datapath):
379381
all_non_nan_table_index = -2
380382
macau_data = datapath('io', 'data', 'macau.html')
@@ -531,6 +533,7 @@ def test_countries_municipalities(self):
531533
res2 = self.read_html(data2, header=0)
532534
assert_framelist_equal(res1, res2)
533535

536+
@pytest.mark.skip(reason='test data removed for copyright reasons')
534537
def test_nyse_wsj_commas_table(self, datapath):
535538
data = datapath('io', 'data', 'nyse_wsj.html')
536539
df = self.read_html(data, index_col=0, header=0,
@@ -671,6 +674,7 @@ def test_parse_dates_combine(self):
671674
newdf = DataFrame({'datetime': raw_dates})
672675
tm.assert_frame_equal(newdf, res[0])
673676

677+
@pytest.mark.skip(reason='test data removed for copyright reasons')
674678
def test_computer_sales_page(self, datapath):
675679
data = datapath('io', 'data', 'computer_sales_page.html')
676680
with tm.assert_raises_regex(ParserError,

0 commit comments

Comments
 (0)