Skip to content

Commit e550963

Browse files
committed
Merge commit 'v0.14.0-213-g741b2fa' into debian
* commit 'v0.14.0-213-g741b2fa': (112 commits) BUG: Bug in .loc performing fallback integer indexing with object dtype indices (GH7496) BUG: Bug in DataFrame.where with a symmetric shaped frame and a passed other of a DataFrame (GH7506) BUG: Bug in timeops with non-aligned Series (GH7500) DOC: Fix index error for remote data docs. [doc fix] minor update to fix latex usepackage syntax Switch if to elif in test_frame.test_to_csv_moar._do_test DOC: Clean up docs for io.data.Options. CI: 3.4 updates ENH: Added method to pandas.data.Options to download all option data for a ticker. Fix indentation: switch to four spaces. (GH6643) BUG: copy certain interpolate arguments to ensure we can write to them; closes pandas-dev#7295. Fix cache key collision and add test for cache key distinctness. DOC: v0.14.1.txt fixes BUG: Bug in Panel.apply with a multi-index as an axis (GH7469) ENH: Cast ndarray-like datetime64 arrays to Index properly DOC: Add missing column header in 'baseball.csv'. CLN: Simplify boxplot and modify its test BUG: astype(float) in Index does the wrong thing FIX: Stata writer no longer ignores encoding when writing strings FIX: Enable fixed width strings to be read from Stata 13 (117) files ...
2 parents a9e2f38 + 741b2fa commit e550963

File tree

127 files changed

+7032
-1820
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

127 files changed

+7032
-1820
lines changed

.travis.yml

+9-11
Original file line numberDiff line numberDiff line change
@@ -34,12 +34,6 @@ matrix:
3434
- CLIPBOARD_GUI=gtk2
3535
- JOB_NAME: "27_nslow"
3636
- DOC_BUILD=true # if rst files were changed, build docs in parallel with tests
37-
- python: 3.2
38-
env:
39-
- NOSE_ARGS="not slow and not disabled"
40-
- FULL_DEPS=true
41-
- CLIPBOARD_GUI=qt4
42-
- JOB_NAME: "32_nslow"
4337
- python: 3.3
4438
env:
4539
- NOSE_ARGS="not slow and not disabled"
@@ -48,11 +42,16 @@ matrix:
4842
- JOB_NAME: "33_nslow"
4943
- python: 3.4
5044
env:
51-
- EXPERIMENTAL=true
5245
- NOSE_ARGS="not slow and not disabled"
5346
- FULL_DEPS=true
5447
- CLIPBOARD=xsel
5548
- JOB_NAME: "34_nslow"
49+
- python: 3.2
50+
env:
51+
- NOSE_ARGS="not slow and not disabled"
52+
- FULL_DEPS=true
53+
- CLIPBOARD_GUI=qt4
54+
- JOB_NAME: "32_nslow"
5655
- python: 2.7
5756
env:
5857
- EXPERIMENTAL=true
@@ -62,13 +61,12 @@ matrix:
6261
- NUMPY_BUILD=master
6362
- PANDAS_TESTING_MODE="deprecate"
6463
allow_failures:
65-
- python: 3.4
64+
- python: 3.2
6665
env:
67-
- EXPERIMENTAL=true
6866
- NOSE_ARGS="not slow and not disabled"
6967
- FULL_DEPS=true
70-
- CLIPBOARD=xsel
71-
- JOB_NAME: "34_nslow"
68+
- CLIPBOARD_GUI=qt4
69+
- JOB_NAME: "32_nslow"
7270
- python: 2.7
7371
env:
7472
- EXPERIMENTAL=true

ci/install.sh

+2-22
Original file line numberDiff line numberDiff line change
@@ -38,32 +38,12 @@ echo "home_dir: [$home_dir]"
3838
# pip==1.5.1
3939
# setuptools==2.2
4040
# wheel==0.22
41-
# nose==1.3.0 (1.3.1 broken for PY3)
41+
# nose==1.3.3
4242

4343
pip install -I -U pip
4444
pip install -I -U setuptools
4545
pip install wheel==0.22
46-
47-
# install nose
48-
pip uninstall nose -y
49-
50-
if [ -n "$EXPERIMENTAL" ]; then
51-
52-
# install from master
53-
rm -Rf /tmp/nose
54-
cd /tmp
55-
git clone --branch master https://github.com/nose-devs/nose.git nose
56-
cd nose
57-
python setup.py install
58-
cd $home_dir
59-
60-
else
61-
62-
# known good version
63-
pip install nose==1.3.0
64-
65-
fi
66-
46+
pip install nose==1.3.3
6747

6848
# comment this line to disable the fetching of wheel files
6949
base_url=http://pandas.pydata.org/pandas-build/dev/wheels

ci/requirements-2.6.txt

+4-2
Original file line numberDiff line numberDiff line change
@@ -6,10 +6,12 @@ http://www.crummy.com/software/BeautifulSoup/bs4/download/4.2/beautifulsoup4-4.2
66
html5lib==1.0b2
77
bigquery==2.0.17
88
numexpr==1.4.2
9-
sqlalchemy==0.8.1
9+
sqlalchemy==0.7.1
10+
pymysql==0.6.0
11+
psycopg2==2.5
1012
scipy==0.11.0
1113
statsmodels==0.4.3
1214
xlwt==0.7.5
13-
openpyxl==1.6.2
15+
openpyxl==2.0.3
1416
xlsxwriter==0.4.6
1517
xlrd==0.9.2

ci/requirements-2.7.txt

+1
Original file line numberDiff line numberDiff line change
@@ -20,3 +20,4 @@ scipy==0.13.3
2020
beautifulsoup4==4.2.1
2121
statsmodels==0.5.0
2222
bigquery==2.0.17
23+
boto==2.26.1

ci/requirements-3.2.txt

-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,5 @@
11
python-dateutil==2.1
22
pytz==2013b
3-
openpyxl==1.6.2
43
xlsxwriter==0.4.6
54
xlrd==0.9.2
65
numpy==1.7.1

ci/requirements-3.4.txt

+4-4
Original file line numberDiff line numberDiff line change
@@ -3,17 +3,17 @@ pytz
33
openpyxl
44
xlsxwriter
55
xlrd
6-
html5lib==1.0b2
6+
html5lib
77
numpy==1.8.0
88
cython==0.20.0
99
scipy==0.13.3
10-
numexpr==2.3
10+
numexpr==2.4
1111
tables==3.1.0
1212
bottleneck==0.8.0
1313
matplotlib==1.3.1
1414
patsy
15-
lxml==3.2.1
15+
lxml==3.3.5
1616
sqlalchemy==0.9.3
1717
pymysql==0.6.1
1818
psycopg2==2.5.2
19-
beautifulsoup4==4.2.1
19+
beautifulsoup4

doc/data/baseball.csv

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
id,year,stint,team,lg,g,ab,r,h,X2b,X3b,hr,rbi,sb,cs,bb,so,ibb,hbp,sh,sf,gidp
1+
id,player,year,stint,team,lg,g,ab,r,h,X2b,X3b,hr,rbi,sb,cs,bb,so,ibb,hbp,sh,sf,gidp
22
88641,womacto01,2006,2,CHN,NL,19,50,6,14,1,0,1,2.0,1.0,1.0,4,4.0,0.0,0.0,3.0,0.0,0.0
33
88643,schilcu01,2006,1,BOS,AL,31,2,0,1,0,0,0,0.0,0.0,0.0,0,1.0,0.0,0.0,0.0,0.0,0.0
44
88645,myersmi01,2006,1,NYA,AL,62,0,0,0,0,0,0,0.0,0.0,0.0,0,0.0,0.0,0.0,0.0,0.0,0.0

doc/make.py

+6-6
Original file line numberDiff line numberDiff line change
@@ -77,10 +77,10 @@ def upload_prev(ver, doc_root='./'):
7777
raise SystemExit('Upload PDF to %s from %s failed' % (ver, doc_root))
7878

7979
def build_pandas():
80-
os.chdir('..')
81-
os.system('python setup.py clean')
82-
os.system('python setup.py build_ext --inplace')
83-
os.chdir('doc')
80+
os.chdir('..')
81+
os.system('python setup.py clean')
82+
os.system('python setup.py build_ext --inplace')
83+
os.chdir('doc')
8484

8585
def build_prev(ver):
8686
if os.system('git checkout v%s' % ver) != 1:
@@ -300,7 +300,7 @@ def _get_config():
300300

301301
import argparse
302302
argparser = argparse.ArgumentParser(description="""
303-
Pandas documentation builder
303+
pandas documentation builder
304304
""".strip())
305305

306306
# argparser.add_argument('-arg_name', '--arg_name',
@@ -325,7 +325,7 @@ def generate_index(api=True, single=False, **kwds):
325325
f.write(t.render(api=api,single=single,**kwds))
326326

327327
import argparse
328-
argparser = argparse.ArgumentParser(description="Pandas documentation builder",
328+
argparser = argparse.ArgumentParser(description="pandas documentation builder",
329329
epilog="Targets : %s" % funcd.keys())
330330

331331
argparser.add_argument('--no-api',

doc/source/10min.rst

+4-4
Original file line numberDiff line numberDiff line change
@@ -22,7 +22,7 @@
2222
2323
2424
********************
25-
10 Minutes to Pandas
25+
10 Minutes to pandas
2626
********************
2727

2828
This is a short introduction to pandas, geared mainly for new users.
@@ -344,7 +344,7 @@ A ``where`` operation with setting.
344344
Missing Data
345345
------------
346346

347-
Pandas primarily uses the value ``np.nan`` to represent missing data. It is by
347+
pandas primarily uses the value ``np.nan`` to represent missing data. It is by
348348
default not included in computations. See the :ref:`Missing Data section
349349
<missing_data>`
350350

@@ -445,7 +445,7 @@ Merge
445445
Concat
446446
~~~~~~
447447

448-
Pandas provides various facilities for easily combining together Series,
448+
pandas provides various facilities for easily combining together Series,
449449
DataFrame, and Panel objects with various kinds of set logic for the indexes
450450
and relational algebra functionality in the case of join / merge-type
451451
operations.
@@ -585,7 +585,7 @@ We can produce pivot tables from this data very easily:
585585
Time Series
586586
-----------
587587

588-
Pandas has simple, powerful, and efficient functionality for performing
588+
pandas has simple, powerful, and efficient functionality for performing
589589
resampling operations during frequency conversion (e.g., converting secondly
590590
data into 5-minutely data). This is extremely common in, but not limited to,
591591
financial applications. See the :ref:`Time Series section <timeseries>`

doc/source/api.rst

+4
Original file line numberDiff line numberDiff line change
@@ -350,6 +350,7 @@ Computations / Descriptive Stats
350350
Series.prod
351351
Series.quantile
352352
Series.rank
353+
Series.sem
353354
Series.skew
354355
Series.std
355356
Series.sum
@@ -642,6 +643,7 @@ Computations / Descriptive Stats
642643
DataFrame.prod
643644
DataFrame.quantile
644645
DataFrame.rank
646+
DataFrame.sem
645647
DataFrame.skew
646648
DataFrame.sum
647649
DataFrame.std
@@ -895,6 +897,7 @@ Computations / Descriptive Stats
895897
Panel.min
896898
Panel.pct_change
897899
Panel.prod
900+
Panel.sem
898901
Panel.skew
899902
Panel.sum
900903
Panel.std
@@ -1222,6 +1225,7 @@ Computations / Descriptive Stats
12221225

12231226
GroupBy.mean
12241227
GroupBy.median
1228+
GroupBy.sem
12251229
GroupBy.std
12261230
GroupBy.var
12271231
GroupBy.ohlc

doc/source/basics.rst

+6-2
Original file line numberDiff line numberDiff line change
@@ -93,7 +93,7 @@ unlike the axis labels, cannot be assigned to.
9393
Accelerated operations
9494
----------------------
9595

96-
Pandas has support for accelerating certain types of binary numerical and boolean operations using
96+
pandas has support for accelerating certain types of binary numerical and boolean operations using
9797
the ``numexpr`` library (starting in 0.11.0) and the ``bottleneck`` libraries.
9898

9999
These libraries are especially useful when dealing with large data sets, and provide large
@@ -428,6 +428,7 @@ optional ``level`` parameter which applies only if the object has a
428428
``prod``, Product of values
429429
``std``, Unbiased standard deviation
430430
``var``, Unbiased variance
431+
``sem``, Unbiased standard error of the mean
431432
``skew``, Unbiased skewness (3rd moment)
432433
``kurt``, Unbiased kurtosis (4th moment)
433434
``quantile``, Sample quantile (value at %)
@@ -1165,6 +1166,9 @@ Thus, a Series of messy strings can be "converted" into a
11651166
like-indexed Series or DataFrame of cleaned-up or more useful strings,
11661167
without necessitating ``get()`` to access tuples or ``re.match`` objects.
11671168

1169+
The results dtype always is object, even if no match is found and the result
1170+
only contains ``NaN``.
1171+
11681172
Named groups like
11691173

11701174
.. ipython:: python
@@ -1556,7 +1560,7 @@ Working with package options
15561560
.. _basics.working_with_options:
15571561
.. versionadded:: 0.10.1
15581562

1559-
Pandas has an options system that let's you customize some aspects of it's behaviour,
1563+
pandas has an options system that let's you customize some aspects of it's behaviour,
15601564
display-related options being those the user is must likely to adjust.
15611565

15621566
Options have a full "dotted-style", case-insensitive name (e.g. ``display.max_rows``),

0 commit comments

Comments
 (0)