Skip to content

Commit ddda265

Browse files
committed
Merge branch 'releases' into debian
* releases: (777 commits) RLS: v0.22.0 DOC: Fix min_count docstring (pandas-dev#19005) DOC: More 0.22.0 updates (pandas-dev#19002) TST: Remove pow test in expressions COMPAT: Avoid td.skip decorator DOC: 0.22.0 release docs (pandas-dev#18983) DOC: Include 0.22.0 whatsnew Breaking changes for sum / prod of empty / all-NA (pandas-dev#18921) ENH: Added a min_count keyword to stat funcs (pandas-dev#18876) RLS: v0.21.1 DOC: Add date to whatsnew (pandas-dev#18740) DOC: Include 0.21.1 whatsnew DOC: Update relase notes (pandas-dev#18739) CFG: Ignore W503 DOC: fix options table (pandas-dev#18730) ENH: support non default indexes in writing to Parquet (pandas-dev#18629) BUG: Fix to_latex with longtable (pandas-dev#17959) (pandas-dev#17960) Parquet: Add error message for no engine found (pandas-dev#18717) BUG: Categorical data fails to load from hdf when all columns are NaN (pandas-dev#18652) DOC: clean-up whatsnew file for 0.21.1 (pandas-dev#18690) ...
2 parents 9611e02 + 1872ee0 commit ddda265

File tree

570 files changed

+36226
-20053
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

570 files changed

+36226
-20053
lines changed

.github/ISSUE_TEMPLATE.md

+12-1
Original file line numberDiff line numberDiff line change
@@ -8,11 +8,22 @@
88

99
[this should explain **why** the current behaviour is a problem and why the expected output is a better solution.]
1010

11+
**Note**: We receive a lot of issues on our GitHub tracker, so it is very possible that your issue has been posted before. Please check first before submitting so that we do not have to handle and close duplicates!
12+
13+
**Note**: Many problems can be resolved by simply upgrading `pandas` to the latest version. Before submitting, please check if that solution works for you. If possible, you may want to check if `master` addresses this issue, but that is not necessary.
14+
15+
For documentation-related issues, you can check the latest versions of the docs on `master` here:
16+
17+
https://pandas-docs.github.io/pandas-docs-travis/
18+
19+
If the issue has not been resolved there, go ahead and file it in the issue tracker.
20+
1121
#### Expected Output
1222

1323
#### Output of ``pd.show_versions()``
1424

1525
<details>
16-
# Paste the output here pd.show_versions() here
26+
27+
[paste the output of ``pd.show_versions()`` here below this line]
1728

1829
</details>

.github/PULL_REQUEST_TEMPLATE.md

+4-4
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
1-
- [ ] closes #xxxx
2-
- [ ] tests added / passed
3-
- [ ] passes ``git diff upstream/master --name-only -- '*.py' | flake8 --diff`` (On Windows, ``git diff upstream/master -u -- "*.py" | flake8 --diff`` might work as an alternative.)
4-
- [ ] whatsnew entry
1+
- [ ] closes #xxxx
2+
- [ ] tests added / passed
3+
- [ ] passes `git diff upstream/master -u -- "*.py" | flake8 --diff`
4+
- [ ] whatsnew entry

.gitignore

+2
Original file line numberDiff line numberDiff line change
@@ -7,6 +7,7 @@
77
*$
88
*.bak
99
*flymake*
10+
*.iml
1011
*.kdev4
1112
*.log
1213
*.swp
@@ -105,3 +106,4 @@ doc/build/html/index.html
105106
doc/tmp.sv
106107
doc/source/styled.xlsx
107108
doc/source/templates/
109+
env/

.pep8speaks.yml

+10
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,10 @@
1+
# File : .pep8speaks.yml
2+
3+
scanner:
4+
diff_only: True # If True, errors caused by only the patch are shown
5+
6+
pycodestyle:
7+
max-line-length: 79
8+
ignore: # Errors and warnings to ignore
9+
- E731
10+
- E402

.travis.yml

+17-10
Original file line numberDiff line numberDiff line change
@@ -16,9 +16,10 @@ cache:
1616

1717
env:
1818
global:
19-
20-
# pandas-docs-travis GH
21-
- secure: "YvvTc+FrSYHgdxqoxn9s8VOaCWjvZzlkaf6k55kkmQqCYR9dPiLMsot1F96/N7o3YlD1s0znPQCak93Du8HHi/8809zAXloTaMSZrWz4R4qn96xlZFRE88O/w/Z1t3VVYpKX3MHlCggBc8MtXrqmvWKJMAqXyysZ4TTzoiJDPvE="
19+
# create a github personal access token
20+
# cd pandas-dev/pandas
21+
# travis encrypt 'PANDAS_GH_TOKEN=personal_access_token' -r pandas-dev/pandas
22+
- secure: "EkWLZhbrp/mXJOx38CHjs7BnjXafsqHtwxPQrqWy457VDFWhIY1DMnIR/lOWG+a20Qv52sCsFtiZEmMfUjf0pLGXOqurdxbYBGJ7/ikFLk9yV2rDwiArUlVM9bWFnFxHvdz9zewBH55WurrY4ShZWyV+x2dWjjceWG5VpWeI6sA="
2223

2324
git:
2425
# for cloning
@@ -36,7 +37,7 @@ matrix:
3637
- JOB="3.5_OSX" TEST_ARGS="--skip-slow --skip-network"
3738
- dist: trusty
3839
env:
39-
- JOB="2.7_LOCALE" TEST_ARGS="--only-slow --skip-network" LOCALE_OVERRIDE="zh_CN.UTF-8"
40+
- JOB="2.7_LOCALE" LOCALE_OVERRIDE="zh_CN.UTF-8" SLOW=true
4041
addons:
4142
apt:
4243
packages:
@@ -61,7 +62,7 @@ matrix:
6162
# In allow_failures
6263
- dist: trusty
6364
env:
64-
- JOB="2.7_SLOW" TEST_ARGS="--only-slow --skip-network"
65+
- JOB="2.7_SLOW" SLOW=true
6566
# In allow_failures
6667
- dist: trusty
6768
env:
@@ -73,11 +74,15 @@ matrix:
7374
# In allow_failures
7475
- dist: trusty
7576
env:
76-
- JOB="3.5_DOC" DOC=true
77+
- JOB="3.6_DOC" DOC=true
78+
addons:
79+
apt:
80+
packages:
81+
- xsel
7782
allow_failures:
7883
- dist: trusty
7984
env:
80-
- JOB="2.7_SLOW" TEST_ARGS="--only-slow --skip-network"
85+
- JOB="2.7_SLOW" SLOW=true
8186
- dist: trusty
8287
env:
8388
- JOB="2.7_BUILD_TEST" TEST_ARGS="--skip-slow" BUILD_TEST=true
@@ -86,7 +91,7 @@ matrix:
8691
- JOB="3.6_NUMPY_DEV" TEST_ARGS="--skip-slow --skip-network" PANDAS_TESTING_MODE="deprecate"
8792
- dist: trusty
8893
env:
89-
- JOB="3.5_DOC" DOC=true
94+
- JOB="3.6_DOC" DOC=true
9095

9196
before_install:
9297
- echo "before_install"
@@ -97,8 +102,6 @@ before_install:
97102
- uname -a
98103
- git --version
99104
- git tag
100-
- ci/before_install_travis.sh
101-
- export DISPLAY=":99.0"
102105

103106
install:
104107
- echo "install start"
@@ -109,13 +112,17 @@ install:
109112

110113
before_script:
111114
- ci/install_db_travis.sh
115+
- export DISPLAY=":99.0"
116+
- ci/before_script_travis.sh
112117

113118
script:
114119
- echo "script start"
115120
- ci/run_build_docs.sh
116121
- ci/script_single.sh
117122
- ci/script_multi.sh
118123
- ci/lint.sh
124+
- echo "checking imports"
125+
- source activate pandas && python ci/check_imports.py
119126
- echo "script done"
120127

121128
after_success:

AUTHORS.md

+57
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,57 @@
1+
About the Copyright Holders
2+
===========================
3+
4+
* Copyright (c) 2008-2011 AQR Capital Management, LLC
5+
6+
AQR Capital Management began pandas development in 2008. Development was
7+
led by Wes McKinney. AQR released the source under this license in 2009.
8+
* Copyright (c) 2011-2012, Lambda Foundry, Inc.
9+
10+
Wes is now an employee of Lambda Foundry, and remains the pandas project
11+
lead.
12+
* Copyright (c) 2011-2012, PyData Development Team
13+
14+
The PyData Development Team is the collection of developers of the PyData
15+
project. This includes all of the PyData sub-projects, including pandas. The
16+
core team that coordinates development on GitHub can be found here:
17+
http://github.com/pydata.
18+
19+
Full credits for pandas contributors can be found in the documentation.
20+
21+
Our Copyright Policy
22+
====================
23+
24+
PyData uses a shared copyright model. Each contributor maintains copyright
25+
over their contributions to PyData. However, it is important to note that
26+
these contributions are typically only changes to the repositories. Thus,
27+
the PyData source code, in its entirety, is not the copyright of any single
28+
person or institution. Instead, it is the collective copyright of the
29+
entire PyData Development Team. If individual contributors want to maintain
30+
a record of what changes/contributions they have specific copyright on,
31+
they should indicate their copyright in the commit message of the change
32+
when they commit the change to one of the PyData repositories.
33+
34+
With this in mind, the following banner should be used in any source code
35+
file to indicate the copyright and license terms:
36+
37+
```
38+
#-----------------------------------------------------------------------------
39+
# Copyright (c) 2012, PyData Development Team
40+
# All rights reserved.
41+
#
42+
# Distributed under the terms of the BSD Simplified License.
43+
#
44+
# The full license is in the LICENSE file, distributed with this software.
45+
#-----------------------------------------------------------------------------
46+
```
47+
48+
Other licenses can be found in the LICENSES directory.
49+
50+
License
51+
=======
52+
53+
pandas is distributed under a 3-clause ("Simplified" or "New") BSD
54+
license. Parts of NumPy, SciPy, numpydoc, bottleneck, which all have
55+
BSD-compatible licenses, are included. Their licenses follow the pandas
56+
license.
57+

LICENSE

+24-82
Original file line numberDiff line numberDiff line change
@@ -1,87 +1,29 @@
1-
=======
2-
License
3-
=======
1+
BSD 3-Clause License
42

5-
pandas is distributed under a 3-clause ("Simplified" or "New") BSD
6-
license. Parts of NumPy, SciPy, numpydoc, bottleneck, which all have
7-
BSD-compatible licenses, are included. Their licenses follow the pandas
8-
license.
9-
10-
pandas license
11-
==============
12-
13-
Copyright (c) 2011-2012, Lambda Foundry, Inc. and PyData Development Team
14-
All rights reserved.
15-
16-
Copyright (c) 2008-2011 AQR Capital Management, LLC
3+
Copyright (c) 2008-2012, AQR Capital Management, LLC, Lambda Foundry, Inc. and PyData Development Team
174
All rights reserved.
185

196
Redistribution and use in source and binary forms, with or without
20-
modification, are permitted provided that the following conditions are
21-
met:
22-
23-
* Redistributions of source code must retain the above copyright
24-
notice, this list of conditions and the following disclaimer.
25-
26-
* Redistributions in binary form must reproduce the above
27-
copyright notice, this list of conditions and the following
28-
disclaimer in the documentation and/or other materials provided
29-
with the distribution.
30-
31-
* Neither the name of the copyright holder nor the names of any
32-
contributors may be used to endorse or promote products derived
33-
from this software without specific prior written permission.
34-
35-
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER AND CONTRIBUTORS
36-
"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
37-
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
38-
A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
39-
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
40-
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
41-
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
42-
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
43-
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
44-
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
7+
modification, are permitted provided that the following conditions are met:
8+
9+
* Redistributions of source code must retain the above copyright notice, this
10+
list of conditions and the following disclaimer.
11+
12+
* Redistributions in binary form must reproduce the above copyright notice,
13+
this list of conditions and the following disclaimer in the documentation
14+
and/or other materials provided with the distribution.
15+
16+
* Neither the name of the copyright holder nor the names of its
17+
contributors may be used to endorse or promote products derived from
18+
this software without specific prior written permission.
19+
20+
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
21+
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
22+
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
23+
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
24+
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
25+
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
26+
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
27+
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
28+
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
4529
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
46-
47-
About the Copyright Holders
48-
===========================
49-
50-
AQR Capital Management began pandas development in 2008. Development was
51-
led by Wes McKinney. AQR released the source under this license in 2009.
52-
Wes is now an employee of Lambda Foundry, and remains the pandas project
53-
lead.
54-
55-
The PyData Development Team is the collection of developers of the PyData
56-
project. This includes all of the PyData sub-projects, including pandas. The
57-
core team that coordinates development on GitHub can be found here:
58-
http://github.com/pydata.
59-
60-
Full credits for pandas contributors can be found in the documentation.
61-
62-
Our Copyright Policy
63-
====================
64-
65-
PyData uses a shared copyright model. Each contributor maintains copyright
66-
over their contributions to PyData. However, it is important to note that
67-
these contributions are typically only changes to the repositories. Thus,
68-
the PyData source code, in its entirety, is not the copyright of any single
69-
person or institution. Instead, it is the collective copyright of the
70-
entire PyData Development Team. If individual contributors want to maintain
71-
a record of what changes/contributions they have specific copyright on,
72-
they should indicate their copyright in the commit message of the change
73-
when they commit the change to one of the PyData repositories.
74-
75-
With this in mind, the following banner should be used in any source code
76-
file to indicate the copyright and license terms:
77-
78-
#-----------------------------------------------------------------------------
79-
# Copyright (c) 2012, PyData Development Team
80-
# All rights reserved.
81-
#
82-
# Distributed under the terms of the BSD Simplified License.
83-
#
84-
# The full license is in the LICENSE file, distributed with this software.
85-
#-----------------------------------------------------------------------------
86-
87-
Other licenses can be found in the LICENSES directory.

MANIFEST.in

+2-1
Original file line numberDiff line numberDiff line change
@@ -1,8 +1,9 @@
11
include MANIFEST.in
22
include LICENSE
33
include RELEASE.md
4-
include README.rst
4+
include README.md
55
include setup.py
6+
include pyproject.toml
67

78
graft doc
89
prune doc/build

0 commit comments

Comments
 (0)