Skip to content

Commit c81ac7b

Browse files
committed
Merge commit 'v0.10.0b1-51-gbbe2fc1' into debian
* commit 'v0.10.0b1-51-gbbe2fc1': (518 commits) BLD: add patsy, numexpr to ci/print_versions.py BUG: fix DataFrame.icol with list of integers when columns are integers with duplicates. close pandas-dev#2259 TST: unit test to assert behavior described in pandas-dev#2525 BUG: compat OrderedDict import for python 2.6 DOC: Emphazise that cython is needed when installing from the repo in install.rst BLD: document pytz as a hard dependency BUG: import OrderedDict from util.compat for 2.6 BUG: df.from_dict should respect OrderedDict 2517 start date -> 7/1/12 ENH: vbench support for HDFStore added benchmarchs to compare (100,000) rows: read/write store read/write store mixed read/write table read/write table wide (200 columns) read/write table mixed query wide/table TST: refactoring to speed up test suite BUG: more floating point error robustness in rolling mean. close pandas-dev#2527 BUG: fix python 3 zip usage DOC: updated HDFStore docs for indexing support and better explanations on how to deal with strings in indexables/values ENH: allow index recreation by calling create_table_index with new parameters BUG: fixed versioning of the data, not reporting correct warnings BUG: fixed string appending when length of subsequent is longer/shorter that existing removed meta data saving disable memory tests (and put a try:except: around it) DOC: small doc change w.r.t. min_itemsize BUG: fixed string truncation in values by passing min_itemsize = { 'values' : 1024 } BUG: non-datetime indicies were not being handled correctly in searchings (via Terms) added support for integer, float, date ...
2 parents 1417cbd + bbe2fc1 commit c81ac7b

File tree

187 files changed

+29841
-10005
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

187 files changed

+29841
-10005
lines changed

.gitignore

+6
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,7 @@
11
*.pyc
22
*.pyo
33
*.swp
4+
.ropeproject
45
build
56
dist
67
MANIFEST
@@ -11,6 +12,7 @@ MANIFEST
1112
*.cpp
1213
*.so
1314
*.pyd
15+
*.h5
1416
pandas/version.py
1517
doc/source/generated
1618
doc/source/_static
@@ -23,3 +25,7 @@ scikits
2325
pandas.egg-info
2426
*\#*\#
2527
.tox
28+
pandas/io/*.dat
29+
pandas/io/*.json
30+
*.log
31+
.noseids

.travis.yml

+42-6
Original file line numberDiff line numberDiff line change
@@ -1,16 +1,52 @@
11
language: python
22

33
python:
4-
- 2.5
54
- 2.6
65
- 2.7
7-
- 3.1
6+
- 3.1 # travis will soon EOL this
87
- 3.2
8+
- 3.3
9+
10+
env:
11+
global:
12+
- # need at least this so travis page will show env column
13+
14+
matrix:
15+
include:
16+
- python: 2.7
17+
env: VBENCH=true
18+
- python: 2.7
19+
env: FULL_DEPS=true
20+
- python: 3.2
21+
env: FULL_DEPS=true
22+
23+
allow_failures:
24+
- python: 2.7
25+
env: VBENCH=true
26+
- python: 3.2
27+
env: FULL_DEPS=true
28+
29+
# allow importing from site-packages,
30+
# so apt-get python-x works for system pythons
31+
# That's 2.7/3.2 on Ubuntu 12.04
32+
virtualenv:
33+
system_site_packages: true
34+
35+
before_install:
36+
- echo "Waldo1"
37+
- echo $VIRTUAL_ENV
38+
- date
39+
- export PIP_ARGS=-q # comment this this to debug travis install issues
40+
- export APT_ARGS=-qq # comment this to debug travis install issues
41+
# - set -x # enable this to see bash commands
42+
- source ci/before_install.sh # we need to source this to bring in the env
43+
- python -V
944

1045
install:
11-
- "if [[ $TRAVIS_PYTHON_VERSION == '2.5' ]]; then pip install --use-mirrors simplejson; fi"
12-
- pip install --use-mirrors cython numpy nose pytz python-dateutil
46+
- echo "Waldo2"
47+
- ci/install.sh
48+
- ci/print_versions.py # not including stats
1349

1450
script:
15-
- python setup.py build_ext install
16-
- nosetests --exe -w /tmp pandas.tests
51+
- echo "Waldo3"
52+
- ci/script.sh

LICENSES/NUMPY_LICENSE

Whitespace-only changes.

LICENSES/PSF_LICENSE

Whitespace-only changes.

LICENSES/SCIPY_LICENSE

Whitespace-only changes.

MANIFEST.in

+1
Original file line numberDiff line numberDiff line change
@@ -23,3 +23,4 @@ global-exclude *.png
2323
# recursive-include examples *.py
2424
# recursive-include doc/source *
2525
# recursive-include doc/sphinxext *
26+
# recursive-include LICENSES *

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,7 +1,7 @@
11
clean:
22
-rm -rf build dist
33

4-
tseries: pandas/src/tseries.pyx
4+
tseries: pandas/lib.pyx pandas/tslib.pyx pandas/hashtable.pyx
55
python setup.py build_ext --inplace
66

77
sparse: pandas/src/sparse.pyx

README.rst

+8-4
Original file line numberDiff line numberDiff line change
@@ -64,19 +64,23 @@ Dependencies
6464

6565
* `NumPy <http://www.numpy.org>`__: 1.6.1 or higher
6666
* `python-dateutil <http://labix.org/python-dateutil>`__ 1.5 or higher
67+
* `pytz <http://pytz.sourceforge.net/>`__
68+
* Needed for time zone support with ``date_range``
6769

6870
Optional dependencies
6971
~~~~~~~~~~~~~~~~~~~~~
7072

7173
* `Cython <http://www.cython.org>`__: Only necessary to build development
72-
version
74+
version. Version 0.17.1 or higher.
7375
* `SciPy <http://www.scipy.org>`__: miscellaneous statistical functions
7476
* `PyTables <http://www.pytables.org>`__: necessary for HDF5-based storage
7577
* `matplotlib <http://matplotlib.sourceforge.net/>`__: for plotting
76-
* `scikits.statsmodels <http://statsmodels.sourceforge.net/>`__
78+
* `statsmodels <http://statsmodels.sourceforge.net/>`__
7779
* Needed for parts of :mod:`pandas.stats`
78-
* `pytz <http://pytz.sourceforge.net/>`__
79-
* Needed for time zone support with ``DateRange``
80+
* `openpyxl <http://packages.python.org/openpyxl/>`__, `xlrd/xlwt <http://www.python-excel.org/>`__
81+
* openpyxl version 1.6.1 or higher
82+
* Needed for Excel I/O
83+
8084

8185
Installation from sources
8286
=========================

RELEASE.rst

+1,908-760
Large diffs are not rendered by default.

ci/before_install.sh

+28
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,28 @@
1+
#!/bin/bash
2+
3+
echo "inside $0"
4+
5+
# overview
6+
if [ ${TRAVIS_PYTHON_VERSION} == "3.3" ]; then
7+
sudo add-apt-repository -y ppa:doko/ppa # we get the py3.3 debs from here
8+
fi
9+
10+
sudo apt-get update $APT_ARGS # run apt-get update for all versions
11+
12+
# hack for broken 3.3 env
13+
if [ x"$VIRTUAL_ENV" == x"" ]; then
14+
VIRTUAL_ENV=~/virtualenv/python$TRAVIS_PYTHON_VERSION_with_system_site_packages;
15+
fi
16+
17+
# we only recreate the virtualenv for 3.x
18+
# since the "Detach bug" only affects python3
19+
# and travis has numpy preinstalled on 2.x which is quicker
20+
_VENV=$VIRTUAL_ENV # save it
21+
if [ ${TRAVIS_PYTHON_VERSION:0:1} == "3" ] ; then
22+
deactivate # pop out of any venv
23+
sudo pip install virtualenv==1.8.4 --upgrade
24+
sudo apt-get install $APT_ARGS python3.3 python3.3-dev
25+
sudo rm -Rf $_VENV
26+
virtualenv -p python$TRAVIS_PYTHON_VERSION $_VENV --system-site-packages;
27+
source $_VENV/bin/activate
28+
fi

ci/install.sh

+64
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,64 @@
1+
#!/bin/bash
2+
3+
echo "inside $0"
4+
# Install Dependencies
5+
6+
# Hard Deps
7+
pip install $PIP_ARGS --use-mirrors cython nose python-dateutil pytz
8+
9+
# try and get numpy as a binary deb
10+
11+
# numpy is preinstalled on 2.x
12+
# if [ ${TRAVIS_PYTHON_VERSION} == "2.7" ]; then
13+
# sudo apt-get $APT_ARGS install python-numpy;
14+
# fi
15+
16+
if [ ${TRAVIS_PYTHON_VERSION} == "3.2" ]; then
17+
sudo apt-get $APT_ARGS install python3-numpy;
18+
fi
19+
20+
# or else, get it with pip and compile it
21+
if [ ${TRAVIS_PYTHON_VERSION:0:1} == "2" ] || \
22+
[ ${TRAVIS_PYTHON_VERSION} == "3.1" ] || \
23+
[ ${TRAVIS_PYTHON_VERSION} == "3.2" ]; then
24+
pip $PIP_ARGS install numpy; #https://github.com/y-p/numpy/archive/1.6.2_with_travis_fix.tar.gz;
25+
else
26+
pip $PIP_ARGS install https://github.com/numpy/numpy/archive/v1.7.0b2.tar.gz;
27+
fi
28+
29+
# Optional Deps
30+
if [ x"$FULL_DEPS" == x"true" ]; then
31+
echo "Installing FULL_DEPS"
32+
if [ ${TRAVIS_PYTHON_VERSION} == "2.7" ]; then
33+
sudo apt-get $APT_ARGS install python-scipy;
34+
fi
35+
36+
if [ ${TRAVIS_PYTHON_VERSION} == "3.2" ]; then
37+
sudo apt-get $APT_ARGS install python3-scipy;
38+
fi
39+
40+
if [ ${TRAVIS_PYTHON_VERSION:0:1} == "2" ]; then
41+
sudo apt-get $APT_ARGS install libhdf5-serial-dev;
42+
pip install numexpr
43+
pip install tables
44+
fi
45+
46+
pip install $PIP_ARGS --use-mirrors openpyxl matplotlib;
47+
pip install $PIP_ARGS --use-mirrors xlrd xlwt;
48+
pip install $PIP_ARGS 'http://downloads.sourceforge.net/project/pytseries/scikits.timeseries/0.91.3/scikits.timeseries-0.91.3.tar.gz?r='
49+
fi
50+
51+
if [ x"$VBENCH" == x"true" ]; then
52+
pip $PIP_ARGS install sqlalchemy git+git://github.com/pydata/vbench.git;
53+
fi
54+
55+
#build and install pandas
56+
python setup.py build_ext install
57+
58+
#HACK: pandas is a statsmodels dependency
59+
# so we need to install it after pandas
60+
if [ x"$FULL_DEPS" == x"true" ]; then
61+
pip install patsy
62+
# pick recent 0.5dev dec/2012
63+
pip install git+git://github.com/statsmodels/statsmodels@c9062e43b8a5f7385537ca95#egg=statsmodels
64+
fi;

ci/print_versions.py

+97
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,97 @@
1+
#!/usr/bin/env python
2+
import sys
3+
4+
print("\nINSTALLED VERSIONS")
5+
print("------------------")
6+
print("Python: %d.%d.%d.%s.%s" % sys.version_info[:])
7+
8+
try:
9+
import Cython
10+
print("Cython: %s" % Cython.__version__)
11+
except:
12+
print("Cython: Not installed")
13+
14+
try:
15+
import numpy
16+
print("Numpy: %s" % numpy.version.version)
17+
except:
18+
print("Numpy: Not installed")
19+
20+
try:
21+
import scipy
22+
print("Scipy: %s" % scipy.version.version)
23+
except:
24+
print("Scipy: Not installed")
25+
26+
try:
27+
import statsmodels
28+
print("statsmodels: %s" % statsmodels.__version__)
29+
except:
30+
print("statsmodels: Not installed")
31+
try:
32+
import patsy
33+
print(" patsy: %s" % patsy.__version__)
34+
except:
35+
print(" patsy: Not installed")
36+
37+
try:
38+
import scikits.timeseries as ts
39+
print("scikits.timeseries: %s" % ts.__version__)
40+
except:
41+
print("scikits.timeseries: Not installed")
42+
43+
try:
44+
import dateutil
45+
print("dateutil: %s" % dateutil.__version__)
46+
except:
47+
print("dateutil: Not installed")
48+
49+
try:
50+
import pytz
51+
print("pytz: %s" % pytz.VERSION)
52+
except:
53+
print("pytz: Not installed")
54+
55+
try:
56+
import tables
57+
print("PyTables: %s" % tables.__version__)
58+
except:
59+
print("PyTables: Not Installed")
60+
61+
try:
62+
import numexpr
63+
print(" numexpr: %s" % numexpr.__version__)
64+
except:
65+
print(" numexpr: Not Installed")
66+
67+
try:
68+
import matplotlib
69+
print("matplotlib: %s" % matplotlib.__version__)
70+
except:
71+
print("matplotlib: Not installed")
72+
73+
try:
74+
import openpyxl
75+
print("openpyxl: %s" % openpyxl.__version__)
76+
except:
77+
print("openpyxl: Not installed")
78+
79+
try:
80+
import xlrd
81+
print("xlrd: %s" % xlrd.__VERSION__)
82+
except:
83+
print("xlrd: Not installed")
84+
85+
try:
86+
import xlwt
87+
print("xlwt: %s" % xlwt.__VERSION__)
88+
except:
89+
print("xlwt: Not installed")
90+
91+
try:
92+
import sqlalchemy
93+
print("sqlalchemy: %s" % sqlalchemy.__version__)
94+
except:
95+
print("sqlalchemy: Not installed")
96+
97+
print("\n")

ci/script.sh

+12
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,12 @@
1+
#!/bin/bash
2+
3+
echo "inside $0"
4+
5+
if [ x"$VBENCH" != x"true" ]; then
6+
nosetests --exe -w /tmp -A "not slow" pandas;
7+
exit
8+
fi
9+
if [ x"$VBENCH" == x"true" ]; then
10+
python vb_suite/perf_HEAD.py;
11+
exit
12+
fi

0 commit comments

Comments
 (0)