Skip to content

Commit b92b878

Browse files
committed
BF: boost min cython to 0.23 (Closes pandas-dev#14699)
1 parent 3ac41ab commit b92b878

7 files changed

+8
-6
lines changed

ci/install_travis.sh

+1-1
Original file line numberDiff line numberDiff line change
@@ -107,7 +107,7 @@ if [ "$BUILD_TEST" ]; then
107107

108108
# build testing
109109
pip uninstall --yes cython
110-
pip install cython==0.19.1
110+
pip install cython==0.23
111111
( python setup.py build_ext --inplace && python setup.py develop ) || true
112112

113113
else

ci/requirements-2.7.build

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
11
python-dateutil=2.4.1
22
pytz=2013b
33
numpy
4-
cython=0.19.1
4+
cython=0.23

ci/requirements-2.7_COMPAT.build

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
11
numpy=1.7.1
2-
cython=0.19.1
2+
cython=0.23
33
dateutil=1.5
44
pytz=2013b

ci/requirements-2.7_LOCALE.build

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,4 +1,4 @@
11
python-dateutil
22
pytz=2013b
33
numpy=1.7.1
4-
cython=0.19.1
4+
cython=0.23

doc/source/install.rst

+1-1
Original file line numberDiff line numberDiff line change
@@ -243,7 +243,7 @@ Optional Dependencies
243243
~~~~~~~~~~~~~~~~~~~~~
244244

245245
* `Cython <http://www.cython.org>`__: Only necessary to build development
246-
version. Version 0.19.1 or higher.
246+
version. Version 0.23 or higher.
247247
* `SciPy <http://www.scipy.org>`__: miscellaneous statistical functions
248248
* `xarray <http://xarray.pydata.org>`__: pandas like handling for > 2 dims, needed for converting Panels to xarray objects. Version 0.7.0 or higher is recommended.
249249
* `PyTables <http://www.pytables.org>`__: necessary for HDF5-based storage. Version 3.0.0 or higher required, Version 3.2.1 or higher highly recommended.

doc/source/whatsnew/v0.20.0.txt

+2
Original file line numberDiff line numberDiff line change
@@ -108,3 +108,5 @@ Performance Improvements
108108

109109
Bug Fixes
110110
~~~~~~~~~
111+
112+
- Require at least 0.23 version of cython to avoid problems with character encodings (:issue:`14699`)

setup.py

+1-1
Original file line numberDiff line numberDiff line change
@@ -27,7 +27,7 @@ def is_platform_mac():
2727
import versioneer
2828
cmdclass = versioneer.get_cmdclass()
2929

30-
min_cython_ver = '0.19.1'
30+
min_cython_ver = '0.23'
3131
try:
3232
import Cython
3333
ver = Cython.__version__

0 commit comments

Comments
 (0)