Skip to content

Commit b606a06

Browse files
committed
Merge commit 'v0.17.0rc1-40-gd1feb49' into debian
* commit 'v0.17.0rc1-40-gd1feb49': (394 commits) DOC: fix ref to template for plot accessor ENH Move check for inferred compression to before `get_filepath_or_buffer` CI: add py3.5 build ENH Enable streaming from S3 Fix Series.nunique groupby with object DOC: Update perf doc for 10953 TST: Fix skipped unit tests in test_ga. Install python-gflags using pip. pandas-dev#11090 ENH Recognize 's3n' and 's3a' as an S3 address DOC: Comparison with SAS BUG: Use StrictVersion instead of LooseVersion when testing for minimum google api client version pandas-dev#10652 BLD: Install google-api-python-client and httplib2 using pip ENH: Add ability to create tables using the gbq module. pandas-dev#8325 TST: make sure to close stata readers asv bench cleanup - groupby DOC: fix plot submethods whatsnew example CI: support *.pip for installations DOC: Modified incorrect doc-string for DataFrameFormatter and removed outdated doc-string (+1 squashed commit) Squashed commits: [068b1fd] DOC: Modified incorrect doc-string for DataFrameFormatter using new doc-string design (+1 squashed commit) Squashed commits: [12e032d] DOC: Updated doc-string using new doc-string design for DataFrameFormatter ENH Enable bzip2 streaming for Python 3 DOC: update release.rst with the highlites DOC: Categorize whatsnew ...
2 parents b819013 + d1feb49 commit b606a06

File tree

370 files changed

+60747
-14217
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

370 files changed

+60747
-14217
lines changed

.binstar.yml

+11-21
Original file line numberDiff line numberDiff line change
@@ -1,22 +1,21 @@
11
package: pandas
22
user: jreback
33

4-
platform:
5-
#- osx-64
6-
#- linux-32
7-
- linux-64
8-
- win-64
9-
#- win-32
10-
11-
engine:
12-
#- python=2.6
13-
- python=2.7
14-
#- python=3.3
15-
#- python=3.4
4+
install:
5+
- conda config --add channels pandas
166

177
before_script:
188
- python -V
199

10+
platform:
11+
- linux-64
12+
#- linux-32
13+
- osx-64
14+
#- win-32
15+
- win-64
16+
engine:
17+
- python=2.7
18+
- python=3.4
2019
script:
2120
- conda build conda.recipe --quiet
2221

@@ -27,12 +26,3 @@ build_targets: conda
2726
notifications:
2827
email:
2928
recipients: ['[email protected]']
30-
31-
---
32-
platform: win-32
33-
engine: python=2.6
34-
exclude: true
35-
---
36-
platform: win-64
37-
engine: python=2.6
38-
exclude: true

.gitattributes

+1
Original file line numberDiff line numberDiff line change
@@ -13,3 +13,4 @@
1313
*.dta binary
1414
*.xls binary
1515
*.xlsx binary
16+
pandas/_version.py export-subst

.gitignore

+4-3
Original file line numberDiff line numberDiff line change
@@ -17,6 +17,7 @@
1717
.idea
1818
.vagrant
1919
.noseids
20+
.ipynb_checkpoints
2021

2122
# Compiled source #
2223
###################
@@ -78,9 +79,9 @@ scikits
7879
*.c
7980
*.cpp
8081

81-
# Things specific to this project #
82-
###################################
83-
pandas/version.py
82+
# Performance Testing #
83+
#######################
84+
asv_bench/
8485

8586
# Documentation generated files #
8687
#################################

.travis.yml

+55-43
Original file line numberDiff line numberDiff line change
@@ -12,131 +12,143 @@ env:
1212
# pandas-docs-bot GH
1313
- secure: "PCzUFR8CHmw9lH84p4ygnojdF7Z8U5h7YfY0RyT+5K/aiQ1ZTU3ZkDTPI0/rR5FVMxsEEKEQKMcc5fvqW0PeD7Q2wRmluloKgT9w4EVEJ1ppKf7lITPcvZR2QgVOvjv4AfDtibLHFNiaSjzoqyJVjM4igjOu8WTlF3JfZcmOQjQ="
1414

15+
git:
16+
# for cloning
17+
depth: 100
18+
1519
matrix:
1620
fast_finish: true
1721
include:
1822
- python: 2.6
1923
env:
24+
- JOB_NAME: "26_nslow_nnet"
2025
- NOSE_ARGS="not slow and not network and not disabled"
2126
- CLIPBOARD=xclip
2227
- LOCALE_OVERRIDE="it_IT.UTF-8"
2328
- BUILD_TYPE=conda
24-
- JOB_NAME: "26_nslow_nnet"
2529
- INSTALL_TEST=true
2630
- python: 2.7
2731
env:
32+
- JOB_NAME: "27_slow_nnet_LOCALE"
2833
- NOSE_ARGS="slow and not network and not disabled"
2934
- LOCALE_OVERRIDE="zh_CN.GB18030"
3035
- FULL_DEPS=true
3136
- JOB_TAG=_LOCALE
3237
- BUILD_TYPE=conda
33-
- JOB_NAME: "27_slow_nnet_LOCALE"
3438
- python: 2.7
3539
env:
40+
- JOB_NAME: "27_nslow"
3641
- NOSE_ARGS="not slow and not disabled"
3742
- FULL_DEPS=true
3843
- CLIPBOARD_GUI=gtk2
3944
- BUILD_TYPE=conda
40-
- JOB_NAME: "27_build_test"
41-
- JOB_TAG=_BUILD_TEST
42-
- BUILD_TEST=true
43-
- python: 2.7
45+
- DOC_BUILD=true # if rst files were changed, build docs in parallel with tests
46+
- python: 3.3
4447
env:
48+
- JOB_NAME: "33_nslow"
4549
- NOSE_ARGS="not slow and not disabled"
4650
- FULL_DEPS=true
47-
- CLIPBOARD_GUI=gtk2
48-
- BUILD_TYPE=pydata
49-
- JOB_NAME: "27_build_test"
50-
- JOB_TAG=_BUILD_TEST
51-
- BUILD_TEST=true
52-
- python: 2.7
51+
- CLIPBOARD=xsel
52+
- BUILD_TYPE=conda
53+
- python: 3.4
5354
env:
55+
- JOB_NAME: "34_nslow"
5456
- NOSE_ARGS="not slow and not disabled"
5557
- FULL_DEPS=true
56-
- CLIPBOARD_GUI=gtk2
58+
- CLIPBOARD=xsel
59+
- BUILD_TYPE=conda
60+
- python: 3.5
61+
env:
62+
- JOB_NAME: "35_nslow"
63+
- NOSE_ARGS="not slow and not network and not disabled"
64+
- FULL_DEPS=true
65+
- CLIPBOARD=xsel
5766
- BUILD_TYPE=conda
58-
- JOB_NAME: "27_nslow"
59-
- DOC_BUILD=true # if rst files were changed, build docs in parallel with tests
6067
- python: 2.7
6168
env:
69+
- JOB_NAME: "27_slow"
70+
- JOB_TAG=_SLOW
6271
- NOSE_ARGS="slow and not network and not disabled"
6372
- FULL_DEPS=true
64-
- JOB_TAG=_SLOW
6573
- BUILD_TYPE=conda
66-
- JOB_NAME: "27_slow"
67-
- python: 3.3
74+
- python: 3.4
6875
env:
69-
- NOSE_ARGS="not slow and not disabled"
76+
- JOB_NAME: "34_slow"
77+
- JOB_TAG=_SLOW
78+
- NOSE_ARGS="slow and not network and not disabled"
7079
- FULL_DEPS=true
7180
- CLIPBOARD=xsel
7281
- BUILD_TYPE=conda
73-
- JOB_NAME: "33_nslow"
74-
- python: 3.4
82+
- python: 2.7
7583
env:
84+
- JOB_NAME: "27_build_test_conda"
85+
- JOB_TAG=_BUILD_TEST
7686
- NOSE_ARGS="not slow and not disabled"
7787
- FULL_DEPS=true
78-
- CLIPBOARD=xsel
7988
- BUILD_TYPE=conda
80-
- JOB_NAME: "34_nslow"
81-
- python: 3.4
89+
- BUILD_TEST=true
90+
- python: 2.7
8291
env:
83-
- NOSE_ARGS="slow and not network and not disabled"
92+
- JOB_NAME: "27_build_test_pydata"
93+
- JOB_TAG=_BUILD_TEST
94+
- NOSE_ARGS="not slow and not disabled"
8495
- FULL_DEPS=true
85-
- JOB_TAG=_SLOW
86-
- CLIPBOARD=xsel
87-
- BUILD_TYPE=conda
88-
- JOB_NAME: "34_slow"
96+
- BUILD_TYPE=pydata
97+
- BUILD_TEST=true
8998
- python: 2.7
9099
env:
91-
- EXPERIMENTAL=true
92-
- NOSE_ARGS="not slow and not network and not disabled"
93100
- JOB_NAME: "27_numpy_master"
94101
- JOB_TAG=_NUMPY_DEV_master
102+
- NOSE_ARGS="not slow and not network and not disabled"
95103
- NUMPY_BUILD=master
96104
- BUILD_TYPE=pydata
97105
- PANDAS_TESTING_MODE="deprecate"
98106
allow_failures:
107+
- python: 3.5
108+
env:
109+
- JOB_NAME: "35_nslow"
110+
- NOSE_ARGS="not slow and not network and not disabled"
111+
- FULL_DEPS=true
112+
- CLIPBOARD=xsel
113+
- BUILD_TYPE=conda
99114
- python: 2.7
100115
env:
116+
- JOB_NAME: "27_slow"
117+
- JOB_TAG=_SLOW
101118
- NOSE_ARGS="slow and not network and not disabled"
102119
- FULL_DEPS=true
103-
- JOB_TAG=_SLOW
104120
- BUILD_TYPE=conda
105-
- JOB_NAME: "27_slow"
106121
- python: 3.4
107122
env:
123+
- JOB_NAME: "34_slow"
124+
- JOB_TAG=_SLOW
108125
- NOSE_ARGS="slow and not network and not disabled"
109126
- FULL_DEPS=true
110-
- JOB_TAG=_SLOW
111127
- CLIPBOARD=xsel
112128
- BUILD_TYPE=conda
113-
- JOB_NAME: "34_slow"
114129
- python: 2.7
115130
env:
116-
- EXPERIMENTAL=true
117-
- NOSE_ARGS="not slow and not network and not disabled"
118131
- JOB_NAME: "27_numpy_master"
119132
- JOB_TAG=_NUMPY_DEV_master
133+
- NOSE_ARGS="not slow and not network and not disabled"
120134
- NUMPY_BUILD=master
121135
- BUILD_TYPE=pydata
122136
- PANDAS_TESTING_MODE="deprecate"
123137
- python: 2.7
124138
env:
139+
- JOB_NAME: "27_build_test_conda"
140+
- JOB_TAG=_BUILD_TEST
125141
- NOSE_ARGS="not slow and not disabled"
126142
- FULL_DEPS=true
127-
- CLIPBOARD_GUI=gtk2
128143
- BUILD_TYPE=conda
129-
- JOB_NAME: "27_build_test"
130-
- JOB_TAG=_BUILD_TEST
131144
- BUILD_TEST=true
132145
- python: 2.7
133146
env:
147+
- JOB_NAME: "27_build_test_pydata"
148+
- JOB_TAG=_BUILD_TEST
134149
- NOSE_ARGS="not slow and not disabled"
135150
- FULL_DEPS=true
136-
- CLIPBOARD_GUI=gtk2
137151
- BUILD_TYPE=pydata
138-
- JOB_NAME: "27_build_test"
139-
- JOB_TAG=_BUILD_TEST
140152
- BUILD_TEST=true
141153

142154
before_install:

MANIFEST.in

+2
Original file line numberDiff line numberDiff line change
@@ -24,3 +24,5 @@ global-exclude *.png
2424
# recursive-include doc/source *
2525
# recursive-include doc/sphinxext *
2626
# recursive-include LICENSES *
27+
include versioneer.py
28+
include pandas/_version.py

README.md

+42-5
Original file line numberDiff line numberDiff line change
@@ -1,8 +1,45 @@
11
# pandas: powerful Python data analysis toolkit
22

3-
[![Build Status](https://travis-ci.org/pydata/pandas.svg?branch=master)](https://travis-ci.org/pydata/pandas)
4-
[![Join the chat at
5-
https://gitter.im/pydata/pandas](https://badges.gitter.im/Join%20Chat.svg)](https://gitter.im/pydata/pandas?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
3+
<table>
4+
<tr>
5+
<td>Latest Release</td>
6+
<td><img src="https://img.shields.io/pypi/v/pandas.svg" alt="latest release" /></td>
7+
</tr>
8+
<tr>
9+
<td>Package Status</td>
10+
<td><img src="https://img.shields.io/pypi/status/pandas.svg" alt="status" /></td>
11+
</tr>
12+
<tr>
13+
<td>License</td>
14+
<td><img src="https://img.shields.io/pypi/l/pandas.svg" alt="license" /></td>
15+
</tr>
16+
<tr>
17+
<td>Build Status</td>
18+
<td>
19+
<a href="https://travis-ci.org/pydata/pandas">
20+
<img src="https://travis-ci.org/pydata/pandas.svg?branch=master" alt="build status" />
21+
</a>
22+
</td>
23+
</tr>
24+
<tr>
25+
<td>Conda</td>
26+
<td>
27+
<a href="http://pandas.pydata.org">
28+
<img src="http://pubbadges.s3-website-us-east-1.amazonaws.com/pkgs-downloads-pandas.png" alt="conda downloads" />
29+
</a>
30+
</td>
31+
</tr>
32+
<tr>
33+
<td>PyPI</td>
34+
<td>
35+
<a href="https://pypi.python.org/pypi/pandas/">
36+
<img src="https://img.shields.io/pypi/dm/pandas.svg" alt="pypi downloads" />
37+
</a>
38+
</td>
39+
</tr>
40+
</table>
41+
42+
[![https://gitter.im/pydata/pandas](https://badges.gitter.im/Join%20Chat.svg)](https://gitter.im/pydata/pandas?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge)
643

744
## What is it
845

@@ -184,15 +221,15 @@ cloning the git repo), execute:
184221
python setup.py install
185222
```
186223

187-
or for installing in [development mode](http://www.pip-installer.org/en/latest/usage.html):
224+
or for installing in [development mode](https://pip.pypa.io/en/latest/reference/pip_install.html#editable-installs):
188225

189226
```sh
190227
python setup.py develop
191228
```
192229

193230
Alternatively, you can use `pip` if you want all the dependencies pulled
194231
in automatically (the `-e` option is for installing it in [development
195-
mode](http://www.pip-installer.org/en/latest/usage.html)):
232+
mode](https://pip.pypa.io/en/latest/reference/pip_install.html#editable-installs)):
196233

197234
```sh
198235
pip install -e .

0 commit comments

Comments
 (0)