Skip to content

Commit b529d62

Browse files
committed
deb_skip_sequencelike_on_armel to prevent FTBFS on armel due to failing test: pandas-dev#4473
1 parent 5729f5e commit b529d62

File tree

3 files changed

+15
-0
lines changed

3 files changed

+15
-0
lines changed

debian/changelog

+2
Original file line numberDiff line numberDiff line change
@@ -8,6 +8,8 @@ pandas (0.13.0-2) unstable; urgency=low
88
0002-remove-explicit-truediv-kwarg.patch
99
to resolve compatibility issues with elderly Numexpr
1010
- 0001-BUG-Yahoo-finance-changed-ichart-url.-Fixed-here.patch
11+
- deb_skip_sequencelike_on_armel to prevent FTBFS on armel due to failing
12+
test: https://github.com/pydata/pandas/issues/4473
1113

1214
-- Yaroslav Halchenko <[email protected]> Fri, 03 Jan 2014 23:13:48 -0500
1315

Original file line numberDiff line numberDiff line change
@@ -0,0 +1,12 @@
1+
--- a/pandas/tests/test_frame.py
2+
+++ b/pandas/tests/test_frame.py
3+
@@ -3953,6 +3953,9 @@ class TestDataFrame(tm.TestCase, CheckIn
4+
self.assert_(len(tst.columns) == 3)
5+
6+
def test_from_records_sequencelike(self):
7+
+ import platform
8+
+ if platform.uname()[4].startswith('armv'):
9+
+ raise nose.SkipTest("Fails on Debian arm boxes due to locales or whatelse")
10+
df = DataFrame({'A' : np.array(np.random.randn(6), dtype = np.float64),
11+
'A1': np.array(np.random.randn(6), dtype = np.float64),
12+
'B' : np.array(np.arange(6), dtype = np.int64),

debian/patches/series

+1
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,4 @@
1+
deb_skip_sequencelike_on_armel
12
0001-BLD-fix-cythonized-msgpack-extension-in-setup.py-GH5.patch
23
0001-Add-division-future-import-everywhere.patch
34
0002-remove-explicit-truediv-kwarg.patch

0 commit comments

Comments
 (0)