Skip to content

Commit 8761da7

Browse files
committed
Merge tag 'v0.11.0rc1' into debian
Version 0.11 RC 1 * tag 'v0.11.0rc1': (647 commits) RLS: version 0.11 release candidate 1 TST: py3 compat on test_pickle.py TST: properly raise the quoted exception when trying to unpickle on py2 BUG: fix raw path to github raw data file DOC add missing arguments to to_datetime docstring PERF: series construction perf enhancements, use a fast path based on dtype PERF/CLN: infer Period in infer_dtype, later index inference is faster TST: run benchmark for repr wide frame with/without interactive mode PERF: fixed int64 indexing perf issue when conversion to int64 DOC: fix typo WIP: finish on pandas-dev#2856 DOC: add docstring BLD: travis make nose test selection clear via env_var BUG: segfault when set_index with MultiIndex. close pandas-dev#3308 BUG: ensure index casting works even in Int64Index ENH: added py3 pickles, revsied to include SparseSeries/SparseDataFrame/Index/MultiIndex BUG: reading py2 pickles in py3 ok now BLD: fix setup.py to load correctly data files ENH: added legacy pickel generation/testing suppport CLN: moved all data for tests to /data sub-dir of the tests ...
2 parents 0167bf9 + 258c7e3 commit 8761da7

File tree

182 files changed

+28399
-8312
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

182 files changed

+28399
-8312
lines changed

.gitignore

+5
Original file line numberDiff line numberDiff line change
@@ -29,3 +29,8 @@ pandas/io/*.dat
2929
pandas/io/*.json
3030
*.log
3131
.noseids
32+
33+
.idea/libraries/sass_stdlib.xml
34+
35+
.idea/pandas.iml
36+
.build_cache_dir

.travis.yml

+4-15
Original file line numberDiff line numberDiff line change
@@ -2,31 +2,20 @@ language: python
22

33
python:
44
- 2.6
5-
- 2.7
6-
# - 3.1 # travis EOL
7-
- 3.2
85
- 3.3
96

107
env:
118
global:
12-
- # need at least this so travis page will show env column
9+
- NOSE_ARGS="not slow" # need at least this so travis page will show env column
1310

1411
matrix:
1512
include:
1613
- python: 2.7
17-
env: VBENCH=true
14+
env: NOSE_ARGS="not network" LOCALE_OVERRIDE="zh_CN.GB18030"
1815
- python: 2.7
19-
env: LOCALE_OVERRIDE="zh_CN.GB18030" # simplified chinese
20-
- python: 2.7
21-
env: FULL_DEPS=true
22-
- python: 3.2
23-
env: FULL_DEPS=true
24-
25-
allow_failures:
26-
- python: 2.7
27-
env: VBENCH=true
16+
env: NOSE_ARGS="not slow" FULL_DEPS=true
2817
- python: 3.2
29-
env: FULL_DEPS=true
18+
env: NOSE_ARGS="not slow" FULL_DEPS=true
3019

3120
# allow importing from site-packages,
3221
# so apt-get python-x works for system pythons

CONTRIBUTING.md

+70-1
Original file line numberDiff line numberDiff line change
@@ -1 +1,70 @@
1-
Please see [Developers](http://pandas.pydata.org/developers.html) page on the project website.
1+
Guidelines
2+
---
3+
4+
All contributions, bug reports, bug fixes, documentation improvments,
5+
enhancements and ideas are welcome.
6+
7+
The Github "issues" tab contains some issues labels "Good as first PR", these are
8+
tasks which do not require deep knowledge of the package. Look those up if you're
9+
looking for a quick way to help out.
10+
11+
Please try and follow these guidelines, as this makes it easier for us to accept
12+
your contribution or address the issue you're having.
13+
14+
- When submitting a bug report:
15+
- Please include a short, self-contained python snippet.
16+
- Specify the pandas version used. (you can check `pandas.__version__`).
17+
- Explain what the expected behavior was, and what you saw instead.
18+
19+
- When submitting a Pull Request
20+
- **Make sure the test suite passes**., and that means on python3 as well.
21+
You can use "test_fast.sh", or tox locally and/or enable Travis-CI on your fork.
22+
- We suggest you enable Travis-CI on your fork, to make it easier for the team
23+
to see that the PR does indeed pass all the tests.
24+
- Back-compatiblitiy **really** matters. Pandas already has a large user-base and
25+
a lot of existing user code. Don't break old code if you can avoid it
26+
Explain the need if there is one in the PR.
27+
Changes to method signatures should be made in a way which doesn't break existing
28+
code, for example you should beware of changes to ordering and naming of keyword
29+
arguments. Add deprecation warnings when needed.
30+
- Performance matters. You can use the included "test_perf.sh"
31+
script to make sure your PR does not introduce any performance regressions
32+
in the library.
33+
- **Don't** merge upstream into a branch you're going to submit as a PR,
34+
This can create all sorts of problems. Use "git rebase" instead. This ensures
35+
no merge conflicts occur when you're code is merged by the core team.
36+
- An informal commit message format is in effect for the project, please try
37+
and adhere to it. View "git log" for examples. Here are some common prefixes
38+
along with general guidelines for when to use them:
39+
- ENH: Enhancement, new functionality
40+
- BUG: Bug fix
41+
- DOC: Additions/updates to documentation
42+
- TST: Additions/updates to tests
43+
- BLD: Updates to the build process/scripts
44+
- PERF: Performance improvement
45+
- CLN: Code cleanup
46+
- Commit messages should have subject line <80 chars, followed by one blank line,
47+
and finally a commit message body if there's a need for one.
48+
- Please reference the GH issue number in your commit message using GH1234
49+
or #1234, either style is fine.
50+
- RELEASE.rst and doc/source/vx.y.z.txt contain an on-going changelog for each
51+
release as it is worked on. Add entries to these files as needed in
52+
a separate commit in your PR, documenting the fix, enhancement or (unavoidable)
53+
breaking change.
54+
- For extra brownie points, use "git rebase -i" to squash and reorder
55+
commits in your PR so that the history makes the most sense. Use your own
56+
judgment to decide what history needs to be preserved.
57+
- On the subject of [PEP8](http://www.python.org/dev/peps/pep-0008/): yes.
58+
- On the subject of massive PEP8 fix PRs touching everything, please consider the following:
59+
- They create merge conflicts for people working in their own fork.
60+
- They makes git blame less effective.
61+
- Different tools / people achieve PEP8 in different styles. This can create
62+
"style wars" and churn that produces little real benefit.
63+
- If your code changes are intermixed with style fixes, they are harder to review
64+
before merging. Keep style fixes in separate commits.
65+
- it's fine to clean-up a little around an area you just worked on.
66+
67+
Having said that, if you still feel a PEP8 storm is in order, go for it.
68+
69+
Please see [Developers](http://pandas.pydata.org/developers.html) page on
70+
the project website for more details.

README.rst

+25-1
Original file line numberDiff line numberDiff line change
@@ -2,6 +2,9 @@
22
pandas: powerful Python data analysis toolkit
33
=============================================
44

5+
.. image:: https://travis-ci.org/pydata/pandas.png
6+
:target: https://travis-ci.org/pydata/pandas
7+
58
What is it
69
==========
710

@@ -67,6 +70,12 @@ Dependencies
6770
* `pytz <http://pytz.sourceforge.net/>`__
6871
* Needed for time zone support with ``date_range``
6972

73+
Highly Recommended Dependencies
74+
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
75+
* `numexpr <http://code.google.com/p/numexpr/>`__: to accelerate some expression evaluation operations
76+
also required by `PyTables`
77+
* `bottleneck <http://berkeleyanalytics.com/bottleneck>`__: to accelerate certain numerical operations
78+
7079
Optional dependencies
7180
~~~~~~~~~~~~~~~~~~~~~
7281

@@ -85,10 +94,25 @@ Optional dependencies
8594
Installation from sources
8695
=========================
8796

88-
In the ``pandas`` directory (same one where you found this file), execute::
97+
To install pandas from source you need ``cython`` in addition to the normal dependencies above,
98+
which can be installed from pypi::
99+
100+
pip install cython
101+
102+
In the ``pandas`` directory (same one where you found this file after cloning the git repo), execute::
89103

90104
python setup.py install
91105

106+
or for installing in `development mode <http://www.pip-installer.org/en/latest/usage.html>`__::
107+
108+
python setup.py develop
109+
110+
Alternatively, you can use `pip` if you want all the dependencies pulled in automatically
111+
(the optional ``-e`` option is for installing it in
112+
`development mode <http://www.pip-installer.org/en/latest/usage.html>`__)::
113+
114+
pip install -e .
115+
92116
On Windows, you will need to install MinGW and execute::
93117

94118
python setup.py build --compiler=mingw32

0 commit comments

Comments
 (0)