Skip to content

Commit 4b02209

Browse files
committed
slight cleanup in debian/rules
1 parent daac6a3 commit 4b02209

File tree

1 file changed

+2
-5
lines changed

1 file changed

+2
-5
lines changed

debian/rules

+2-5
Original file line numberDiff line numberDiff line change
@@ -18,16 +18,15 @@ PY3VERS = $(shell py3versions -vr)
1818
PY3VER = $(shell py3versions -vd)
1919

2020
UVER := $(shell LC_ALL=C dpkg-parsechangelog | awk '/^Version:/{print $$2;}' | sed -e 's,-[^-]*$$,,g')
21-
CYTHON2VER := $(shell dpkg -l cython | awk '/^ii/{print $$3;}' || echo 0)
22-
CYTHON3VER := $(shell dpkg -l cython3 2>/dev/null | awk '/^ii/{print $$3;}' || echo 0)
23-
MPLVER := $(shell dpkg -l python-matplotlib | awk '/^ii/{print $$3;}' || echo 0)
2421

2522
MIN_CYTHONVER = 0.17.1
2623

2724
# Some unittests might need to be excluded for different Python versions
2825
EXCLUDE_TESTS2 :=
2926
EXCLUDE_TESTS3.2 := --exclude "test_bootstrap_plot"
3027
EXCLUDE_TESTS3.3 := --exclude "test_(bootstrap_plot|quoting|cant_compare_tz_naive_w_aware|more_flexible_frame_multi_function|yahoo)"
28+
29+
# MPLVER := $(shell dpkg -l python-matplotlib | awk '/^ii/{print $$3;}' || echo 0)
3130
# $(shell dpkg --compare-versions $(MPLVER) lt 1.0 && echo '|test_hist|test_plot|test_boxplot|test_corr_rank' || echo '')
3231

3332
# Mega rule
@@ -63,8 +62,6 @@ override_dh_auto_build:
6362

6463
override_dh_auto_install: ${PYVERS:%=python-install%} ${PY3VERS:%=python-install%} ${PYVERS:%=python-test%} ${PY3VERS:%=python-test%}
6564
# Per Python version logic -- install, test, remomove .so (installed into -lib)
66-
# Unfortunately mighty make doesn't have a sensible function to return the first
67-
# character of a string
6865
python-install%:
6966
echo "$*" | grep -q '^3' && PY=3 || PY= ; \
7067
CYTHONVER=$$(dpkg -l cython$$PY 2>/dev/null | awk '/^ii/{print $$3;}' || echo 0); \

0 commit comments

Comments
 (0)