Skip to content

Commit 4873168

Browse files
committed
debian/rules,patches - save debian-based version into __version.py, so doesn't conflict with upstream tests of public API
1 parent 64758fe commit 4873168

File tree

3 files changed

+7
-6
lines changed

3 files changed

+7
-6
lines changed

debian/changelog

+4-1
Original file line numberDiff line numberDiff line change
@@ -3,8 +3,11 @@ pandas (0.18.1+git25-ga7469cf-1) unstable; urgency=medium
33
* New upstream snapshot from v0.19.0rc1-25-ga7469cf
44
* debian/patches
55
- dropped changeset_ and up_ patches adopted upstream, refreshed the rest
6+
* debian/rules,patches
7+
- save debian-based version into __version.py, so doesn't conflict with
8+
upstream tests of public API
69

7-
-- Yaroslav Halchenko <[email protected]> Tue, 20 Sep 2016 13:13:17 -0400
10+
-- Yaroslav Halchenko <[email protected]> Tue, 20 Sep 2016 22:31:17 -0400
811

912
pandas (0.18.1-1) unstable; urgency=medium
1013

debian/patches/deb_nonversioneer_version

+1-1
Original file line numberDiff line numberDiff line change
@@ -8,4 +8,4 @@
88
-v = get_versions()
99
-__version__ = v.get('closest-tag',v['version'])
1010
-del get_versions, v
11-
+from .version import version as __version__
11+
+from .__version import version as __version__

debian/rules

+2-4
Original file line numberDiff line numberDiff line change
@@ -79,12 +79,10 @@ override_dh_clean: clean_generated
7979
[ "$(UVER)" = "`cat debian/cythonized-files/VERSION`" ]
8080
rm -rf build doc/_build *-stamp # pandas.egg-info pandas/datasets/__config__.py
8181
dh_clean
82-
: # prune auto-generated version.py -- will be generated during build again
83-
rm -f pandas/version.py
8482

8583
version_py:
86-
[ -e pandas/version.py ] || \
87-
echo -e "version = '$(UVER_PY)'\nshort_version = '$(UVER_PYSHORT)'" > pandas/version.py
84+
[ -e pandas/__version.py ] || \
85+
echo -e "version = '$(UVER_PY)'\nshort_version = '$(UVER_PYSHORT)'" > pandas/__version.py
8886

8987
override_dh_auto_build: version_py
9088
# Override default build operation which --force's re-cythonization

0 commit comments

Comments
 (0)