Skip to content

Commit 3275685

Browse files
committed
Merge commit 'v0.12.0rc1-43-g7b2eaa4' into debian
* commit 'v0.12.0rc1-43-g7b2eaa4': (571 commits) PERF: add ix scalar get benchmark DOC: more prominent HDFStore store docs about storer/table formats BUG: invert_xaxis (negative tot_sec) triggers MilliSecondLocator (pandas-dev#3990) BUG: (GH4192) fixed broken unit test BUG: (GH4192) Fixed buglet in the broadcasting logic in Series.where CLN: Ignore warnings generated by 'DROP TABLE IF EXISTS' when table does not exist. DOC: more cookbook recipies DOC: update ipython_directive with changes from ipython to restart prompt number at 1 each page DOC: increased width of text area TST: fix ujson tests failures on 32-bit TST: raise when no data are found when trying to dld multiple symbols TST: Create a MySQL database and run MySQL tests on Travis. CLN: write the attributes in a HDFStore as strings TST: remove double call to yahoo finance DOC to_datetime warning about dayfirst strictness TST: to_datetime format fixes DOC: minor io/whatsnew doc edits BUG/TST: wrong parsing of microseconds with format arg (pandas-dev#4152) RLS: first release candidate for v0.12.0 BLD: use the wheel url for scikits timeseries ...
2 parents 6173863 + 7b2eaa4 commit 3275685

File tree

221 files changed

+42079
-11537
lines changed

Some content is hidden

Large Commits have some content hidden by default. Use the searchbox below for content that may be hidden.

221 files changed

+42079
-11537
lines changed

.gitattributes

+15
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,15 @@
1+
* text=auto
2+
# enforce text on certain files
3+
*.py text
4+
*.pyx text
5+
*.pyd text
6+
*.c text
7+
*.h text
8+
*.html text
9+
*.csv text
10+
*.json text
11+
*.pickle binary
12+
*.h5 binary
13+
*.dta binary
14+
*.xls binary
15+
*.xlsx binary

.gitignore

+5-1
Original file line numberDiff line numberDiff line change
@@ -13,6 +13,7 @@ MANIFEST
1313
*.so
1414
*.pyd
1515
*.h5
16+
*.dta
1617
pandas/version.py
1718
doc/source/generated
1819
doc/source/_static
@@ -33,4 +34,7 @@ pandas/io/*.json
3334
.idea/libraries/sass_stdlib.xml
3435

3536
.idea/pandas.iml
36-
.build_cache_dir
37+
.build_cache_dir
38+
.vagrant
39+
*.whl
40+
**/wheelhouse/*

.travis.yml

+7-14
Original file line numberDiff line numberDiff line change
@@ -5,26 +5,18 @@ python:
55

66
env:
77
global:
8-
- secure: "O04RU5QRKEDL/SrIWEsVe8O+1TxZqZQSa28Sd+Fz48NW/XddhefYyxzqcUXh\nk/NjWMqknJRQhApLolBianVpsE577OTllzlcyKn3nUL6hjOXcoszGaYray7S\niNGKGyO8xrtB/ZQDtmupz0ksK8sLoCTscdiGotFulczbx0zt+4g="
9-
- secure: "PUJ9nC1/v2vpFUtELSoSjI53OHCVXfFTb8+t5lIGIqHtjUBkhiJSNPfCv8Bx\ndsdrx30qP8KsSceYzaa/bog6p8YNU1iih23S0KbjucutvA0LNHBTNvnxmjBR\nSJfKd5FmwnXvizRyghYBzmQ3NmGO7ADw2DBwKOhgGMqCHZ8Tlc8="
10-
- secure: "IDcMrCCW+6pgJtsI3Q163OPc0iec1ogpitaqiRhHcrEBUCXZgVeclOeiZBlw\n/u+uGyW/O0NhHMaFXKB8BdDVwlQEEHv48syN6npS/A5+O6jriWKL4ozttOhE\npOlu+yLhHnEwx6wZVIHRTVn+t1GkOrjlBcjaQi+Z13G3XmDaSG8="
11-
- secure: "Zu9aj0dTGpvMqT/HqBGQgDYl/v5ubC7lFwfE8Fqb0N1UVXqbpjXnNH/7oal1\nUsIT7klO++LWm+LxsP/A1FWENTSgdYe99JQtNyauW+0x5YR1JTuDJ8atDgx9\nSq66CaVpS5t+ov7UVm2bKSUX+1S8+8zGbIDADrMxEzYEMF7WoGM="
12-
- secure: "AfIvLxvCxj22zrqg3ejGf/VePKT2AyGT9erYzlKpBS0H8yi5Pp1MfmJjhaR4\n51zBtzqHPHiIEY6ZdE06o9PioMWkXS+BqJNrxGSbt1ltxgOFrxW5zOpwiFGZ\nZOv1YeFkuPf8PEsWT7615mdydqTQT7B0pqUKK/d6aka4TQ/tg5Q="
13-
- secure: "EM4ySBUusReNu7H1QHXvjnP/J1QowvfpwEBmjysYxJuq7KcG8HhhlfpUF+Gh\nLBzLak9QBA67k4edhum3qtKuJR5cHuja3+zuV8xmx096B/m96liJFTrwZpea\n58op3W6ZULctEpQNgIkyae20bjxl4f99JhZRUlonoPfx/rBIMFc="
14-
- secure: "pgMYS/6MQqDGb58qdzTJesvAMmcJWTUEEM8gf9rVbfqfxceOL4Xpx8siR9B2\nC4U4MW1cHMPP3RFEb4Jy0uK49aHH10snwZY1S84YPPllpH5ZFXVdN68OayNj\nh4k5N/2hhaaQuJ6Uh8v8s783ye4oYTOW5RJUFqQu4QdG4IkTIMs="
15-
168
- NOSE_ARGS="not slow" UPLOAD=true
179

1810
matrix:
1911
include:
2012
- python: 2.7
21-
env: NOSE_ARGS="slow and not network" LOCALE_OVERRIDE="zh_CN.GB18030" FULL_DEPS=true UPLOAD=false
13+
env: NOSE_ARGS="slow and not network" LOCALE_OVERRIDE="zh_CN.GB18030" FULL_DEPS=true JOB_TAG=_LOCALE
2214
- python: 2.7
23-
env: NOSE_ARGS="not slow" FULL_DEPS=true UPLOAD=true
15+
env: NOSE_ARGS="not slow" FULL_DEPS=true
2416
- python: 3.2
25-
env: NOSE_ARGS="not slow" FULL_DEPS=true UPLOAD=true
17+
env: NOSE_ARGS="not slow" FULL_DEPS=true
2618
- python: 3.3
27-
env: NOSE_ARGS="not slow" UPLOAD=true
19+
env: NOSE_ARGS="not slow" FULL_DEPS=true
2820

2921
# allow importing from site-packages,
3022
# so apt-get python-x works for system pythons
@@ -41,18 +33,19 @@ before_install:
4133
# - export APT_ARGS=-qq # comment this to debug travis install issues
4234
# - set -x # enable this to see bash commands
4335
- export ZIP_FLAGS=-q # comment this to debug travis install issues
44-
- source ci/envars.sh # we need to source this to bring in the envars
4536
- ci/before_install.sh
4637
- python -V
4738

4839
install:
4940
- echo "Waldo2"
5041
- ci/install.sh
5142

43+
before_script:
44+
- mysql -e 'create database pandas_nosetest;'
45+
5246
script:
5347
- echo "Waldo3"
5448
- ci/script.sh
5549

5650
after_script:
5751
- ci/print_versions.py
58-
- ci/after_script.sh

CONTRIBUTING.md

+72-9
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,4 @@
1-
Guidelines
2-
---
1+
###Guidelines
32

43
All contributions, bug reports, bug fixes, documentation improvments,
54
enhancements and ideas are welcome.
@@ -12,13 +11,27 @@ Please try and follow these guidelines, as this makes it easier for us to accept
1211
your contribution or address the issue you're having.
1312

1413
- When submitting a bug report:
15-
- Please include a short, self-contained python snippet.
16-
- Specify the pandas version used. (you can check `pandas.__version__`).
14+
- Please include a short, self-contained python snippet reproducing the problem.
15+
You can have the code formatted nicely by using [GitHub Flavored Markdown](http://github.github.com/github-flavored-markdown/) :
16+
17+
```
18+
```python
19+
20+
print("I ♥ pandas!")
21+
22+
``'
23+
```
24+
25+
- Specify the pandas (and numpy) version used. (you can check `pandas.__version__`).
1726
- Explain what the expected behavior was, and what you saw instead.
27+
- If the issue seems to involve some of pandas' dependencies such as matplotlib
28+
or PyTables, you should include (the relavent parts of) the output of
29+
[ci/print_versions.py](https://github.com/pydata/pandas/blob/master/ci/print_versions.py)
1830
1931
- When submitting a Pull Request
2032
- **Make sure the test suite passes**., and that means on python3 as well.
21-
You can use "test_fast.sh", or tox locally and/or [enable Travis-CI](http://about.travis-ci.org/docs/user/getting-started/) on your fork.
33+
You can use "test_fast.sh", or tox locally and/or enable Travis-CI on your fork.
34+
See the "Getting Travis-CI going" below.
2235
- We suggest you enable Travis-CI on your fork, to make it easier for the team
2336
to see that the PR does indeed pass all the tests.
2437
- Back-compatiblitiy **really** matters. Pandas already has a large user-base and
@@ -30,6 +43,7 @@ your contribution or address the issue you're having.
3043
- Performance matters. You can use the included "test_perf.sh"
3144
script to make sure your PR does not introduce any performance regressions
3245
in the library.
46+
- docstrings follow the [numpydoc](https://github.com/numpy/numpy/blob/master/doc/HOWTO_DOCUMENT.rst.txt) format.
3347
- **Don't** merge upstream into a branch you're going to submit as a PR,
3448
This can create all sorts of problems. Use "git rebase" instead. This ensures
3549
no merge conflicts occur when you're code is merged by the core team.
@@ -57,10 +71,10 @@ your contribution or address the issue you're having.
5771
5872
which fails on python 2.6, use `self.assertRaises(TheException,func,args)` instead.
5973
60-
- RELEASE.rst and doc/source/vx.y.z.txt contain an on-going changelog for each
61-
release as it is worked on. Add entries to these files as needed in
62-
a separate commit in your PR, documenting the fix, enhancement or (unavoidable)
63-
breaking change.
74+
- doc/source/release.rst and doc/source/vx.y.z.txt contain an on-going
75+
changelog for each release as it is worked on. Add entries to these files
76+
as needed in a separate commit in your PR, documenting the fix, enhancement
77+
or (unavoidable) breaking change.
6478
- For extra brownie points, use "git rebase -i" to squash and reorder
6579
commits in your PR so that the history makes the most sense. Use your own
6680
judgment to decide what history needs to be preserved.
@@ -77,5 +91,54 @@ your contribution or address the issue you're having.
7791
7892
Having said that, if you still feel a PEP8 storm is in order, go for it.
7993
94+
### Notes on plotting functions convention
95+
96+
https://groups.google.com/forum/#!topic/pystatsmodels/biNlCvJPNNY/discussion
97+
98+
###Getting Travis-CI going
99+
100+
Instructions for getting Travis-CI installed are available [here](http://about.travis-ci.org/docs/user/getting-started/). For those users who are new to travis-ci and continuous-integration in particular,
101+
Here's a few high-level notes:
102+
- Travis-CI is a free service (with premium account available), that integrates
103+
well with Github.
104+
- Enabling Travis-CI on your github fork of a project will cause any *new* commit
105+
pushed to the repo to trigger a full build+test on Travis-CI's servers.
106+
- All the configuration for travis's builds is already specified by .travis.yml in the repo,
107+
That means all you have to do is enable Travis-CI once, and then just push commits
108+
and you'll get full testing across py2/3 with pandas's considerable test-suite.
109+
- Enabling travis-CI will attach the test results (red/green) to the Pull-Request
110+
page for any PR you submit. For example:
111+
112+
https://github.com/pydata/pandas/pull/2532,
113+
114+
See the Green "Good to merge!" banner? that's it.
115+
116+
This is especially important for new contributors, as memebers of the pandas dev team
117+
like to know the test suite passes before considering it for merging.
118+
Even regular contributors who test religiously on their local box (using tox
119+
for example) often rely on a PR+travis=green to make double sure everything
120+
works ok on another system, as occasionally, it doesn't.
121+
122+
####Steps to enable Travis-CI
123+
124+
- go to https://travis-ci.org/
125+
- "Sign in with Github", on top panel.
126+
- \[your username\]/Account, on top-panel.
127+
- 'sync now' to refresh the list of repos on your GH account.
128+
- flip the switch on the repos you want Travis-CI enabled for,
129+
"pandas" obviously.
130+
- Then, pushing a *new* commit to a certain branch on that repo
131+
will trigger a build/test for that branch, for example the branch
132+
might be "master" or "PR1234_fix_all_the_things", if that's the
133+
name of your PR branch.
134+
135+
You can see the build history and current builds for your fork
136+
on: https://travis-ci.org/(your_GH_username)/pandas.
137+
138+
For example, the builds for the main pandas repo can be seen at:
139+
https://travis-ci.org/pydata/pandas.
140+
141+
####More developer docs
142+
80143
Please see [Developers](http://pandas.pydata.org/developers.html) page on
81144
the project website for more details.

LICENSES/OTHER

+49-1
Original file line numberDiff line numberDiff line change
@@ -29,4 +29,52 @@ SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
2929
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
3030
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
3131
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
32-
POSSIBILITY OF SUCH DAMAGE.
32+
POSSIBILITY OF SUCH DAMAGE.
33+
34+
google-api-python-client license
35+
--------------------------------
36+
37+
Copyright (C) 2012 Google Inc.
38+
All rights reserved.
39+
40+
Licensed under the Apache License, Version 2.0 (the "License");
41+
you may not use this file except in compliance with the License.
42+
You may obtain a copy of the License at
43+
44+
http://www.apache.org/licenses/LICENSE-2.0
45+
46+
Unless required by applicable law or agreed to in writing, software
47+
distributed under the License is distributed on an "AS IS" BASIS,
48+
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
49+
See the License for the specific language governing permissions and
50+
limitations under the License.
51+
52+
Pyperclip v1.3 license
53+
----------------------
54+
55+
Copyright (c) 2010, Albert Sweigart
56+
All rights reserved.
57+
58+
BSD-style license:
59+
60+
Redistribution and use in source and binary forms, with or without
61+
modification, are permitted provided that the following conditions are met:
62+
* Redistributions of source code must retain the above copyright
63+
notice, this list of conditions and the following disclaimer.
64+
* Redistributions in binary form must reproduce the above copyright
65+
notice, this list of conditions and the following disclaimer in the
66+
documentation and/or other materials provided with the distribution.
67+
* Neither the name of the pyperclip nor the
68+
names of its contributors may be used to endorse or promote products
69+
derived from this software without specific prior written permission.
70+
71+
THIS SOFTWARE IS PROVIDED BY Albert Sweigart "AS IS" AND ANY
72+
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
73+
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
74+
DISCLAIMED. IN NO EVENT SHALL Albert Sweigart BE LIABLE FOR ANY
75+
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
76+
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
77+
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
78+
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
79+
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
80+
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

LICENSES/ULTRAJSON_LICENSE

+34
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,34 @@
1+
Copyright (c) 2011-2013, ESN Social Software AB and Jonas Tarnstrom
2+
All rights reserved.
3+
4+
Redistribution and use in source and binary forms, with or without
5+
modification, are permitted provided that the following conditions are met:
6+
* Redistributions of source code must retain the above copyright
7+
notice, this list of conditions and the following disclaimer.
8+
* Redistributions in binary form must reproduce the above copyright
9+
notice, this list of conditions and the following disclaimer in the
10+
documentation and/or other materials provided with the distribution.
11+
* Neither the name of the ESN Social Software AB nor the
12+
names of its contributors may be used to endorse or promote products
13+
derived from this software without specific prior written permission.
14+
15+
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
16+
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
17+
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
18+
DISCLAIMED. IN NO EVENT SHALL ESN SOCIAL SOFTWARE AB OR JONAS TARNSTROM BE LIABLE
19+
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
20+
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
21+
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
22+
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
23+
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
24+
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
25+
26+
27+
Portions of code from MODP_ASCII - Ascii transformations (upper/lower, etc)
28+
http://code.google.com/p/stringencoders/
29+
Copyright (c) 2007 Nick Galbreath -- nickg [at] modp [dot] com. All rights reserved.
30+
31+
Numeric decoder derived from from TCL library
32+
http://www.opensource.apple.com/source/tcl/tcl-14/tcl/license.terms
33+
* Copyright (c) 1988-1993 The Regents of the University of California.
34+
* Copyright (c) 1994 Sun Microsystems, Inc.

MANIFEST.in

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
include MANIFEST.in
22
include LICENSE
3-
include RELEASE.rst
3+
include RELEASE.md
44
include README.rst
55
include TODO.rst
66
include setup.py

Makefile

+22-6
Original file line numberDiff line numberDiff line change
@@ -1,11 +1,27 @@
1-
clean:
2-
-rm -rf build dist
3-
41
tseries: pandas/lib.pyx pandas/tslib.pyx pandas/hashtable.pyx
52
python setup.py build_ext --inplace
63

4+
.PHONY : clean develop build clean clean_pyc tseries doc
5+
6+
clean: clean_pyc
7+
-rm -rf build dist
8+
-find . -name '*.so' -exec rm {} \;
9+
10+
clean_pyc:
11+
-find . -name '*.pyc' -exec rm {} \; -or -name '*.pyo' -exec rm {} \;
12+
713
sparse: pandas/src/sparse.pyx
8-
-python setup.py build_ext --inplace
14+
python setup.py build_ext --inplace
15+
16+
build: clean_pyc
17+
python setup.py build_ext --inplace
18+
19+
develop: build
20+
-python setup.py develop
921

10-
test: sparse
11-
-python pandas/tests/test_libsparse.py
22+
doc:
23+
-rm -rf doc/build
24+
-rm -rf doc/source/generated
25+
cd doc; \
26+
python make.py clean; \
27+
python make.py html

0 commit comments

Comments
 (0)