Skip to content

Commit 2965e13

Browse files
committed
Merge tag 'v0.16.0' into debian
Version 0.16.0 * tag 'v0.16.0': (24 commits) RLS: v0.16.0 final DOC: update release notes, v0.16.0.txt DOC: further clean-up whatsnew file DOC: add v0.16.1.txt starter template TST: remove old tests that just skipped Added itertools.groupby equivalent example. COMPAT: windows dtype fix on series formatting tests DOC: io.rst fixups DOC: example of pandas to R transfer of DataFrame using HDF5 file DOC: grammar fixes, add conda install to README DOC: don't create backlinks in the whatsnew section FIX: Series text representation PERF: optimize memory usage for to_hdf API: spurious setting_with_copy warning (GH8730) DOC: organize stringmethods whatsnew CI: don't remove python-dateutil at end of install COMPAT: dtype conform on windows for panel construct from a scalar COMPAT: odd arrays can be correctly ordered in newer versions of numpy support constructing Panel or Panel4D with scalar data, fixes pandas-dev#8285 DOC: Fix heading level for assign ...
2 parents 16016aa + c91bdba commit 2965e13

29 files changed

+940
-607
lines changed

CONTRIBUTING.md

+1-1
Original file line numberDiff line numberDiff line change
@@ -19,7 +19,7 @@ looking for a quick way to help out.
1919
...
2020
```
2121

22-
- Include the full version string of pandas and it's dependencies. In recent (>0.12) versions
22+
- Include the full version string of pandas and its dependencies. In recent (>0.12) versions
2323
of pandas you can use a built in function:
2424

2525
```python

README.md

+6
Original file line numberDiff line numberDiff line change
@@ -87,6 +87,12 @@ or `pip`:
8787
pip install pandas
8888
```
8989

90+
or `conda`:
91+
92+
```sh
93+
conda install pandas
94+
```
95+
9096
## Dependencies
9197
- [NumPy](http://www.numpy.org): 1.7.0 or higher
9298
- [python-dateutil](http://labix.org/python-dateutil): 1.5 or higher

ci/install_conda.sh

+1-1
Original file line numberDiff line numberDiff line change
@@ -98,7 +98,7 @@ fi
9898

9999
python setup.py build_ext --inplace && python setup.py develop
100100

101-
for package in beautifulsoup4 'python-dateutil'; do
101+
for package in beautifulsoup4; do
102102
pip uninstall --yes $package
103103
done
104104

doc/source/categorical.rst

+3-3
Original file line numberDiff line numberDiff line change
@@ -386,9 +386,9 @@ categories or a categorical with any list-like object, will raise a TypeError.
386386

387387
.. ipython:: python
388388
389-
cat = Series(Categorical([1,2,3], categories=[3,2,1]))
390-
cat_base = Series(Categorical([2,2,2], categories=[3,2,1]))
391-
cat_base2 = Series(Categorical([2,2,2]))
389+
cat = Series([1,2,3]).astype("category", categories=[3,2,1], ordered=True)
390+
cat_base = Series([2,2,2]).astype("category", categories=[3,2,1], ordered=True)
391+
cat_base2 = Series([2,2,2]).astype("category", ordered=True)
392392
393393
cat
394394
cat_base

doc/source/comparison_with_r.rst

+4
Original file line numberDiff line numberDiff line change
@@ -27,6 +27,10 @@ libraries, we care about the following things:
2727
This page is also here to offer a bit of a translation guide for users of these
2828
R packages.
2929

30+
For transfer of ``DataFrame`` objects from ``pandas`` to R, one option is to
31+
use HDF5 files, see :ref:`io.external_compatibility` for an
32+
example.
33+
3034
Base R
3135
------
3236

0 commit comments

Comments
 (0)