Skip to content

Commit 1c24700

Browse files
committed
up_tag_yahoo_test_requiring_network patch cherry-picked from upstream GIT so that tests would not be excercised at package build time (Closes: #681449)
1 parent f5a1bc9 commit 1c24700

File tree

3 files changed

+39
-0
lines changed

3 files changed

+39
-0
lines changed

debian/changelog

+8
Original file line numberDiff line numberDiff line change
@@ -1,3 +1,11 @@
1+
pandas (0.8.0-2) unstable; urgency=medium
2+
3+
* up_tag_yahoo_test_requiring_network patch cherry-picked from upstream
4+
GIT so that tests would not be excercised at package build time
5+
(Closes: #681449)
6+
7+
-- Yaroslav Halchenko <[email protected]> Fri, 13 Jul 2012 08:54:41 -0400
8+
19
pandas (0.8.0-1) unstable; urgency=low
210

311
* Fresh upstream release

debian/patches/series

+1
Original file line numberDiff line numberDiff line change
@@ -0,0 +1 @@
1+
up_tag_yahoo_test_requiring_network
Original file line numberDiff line numberDiff line change
@@ -0,0 +1,30 @@
1+
From: Wes McKinney <[email protected]>
2+
Date: Thu, 12 Jul 2012 17:36:23 -0400
3+
Subject: [PATCH] BUG: fix duplicate index indexing problems close #1201
4+
5+
Partially taken from
6+
4406d37b71cc3303b40847010299534c03723651
7+
8+
diff --git a/pandas/io/tests/test_yahoo.py b/pandas/io/tests/test_yahoo.py
9+
index 9f123e0..1f10a86 100644
10+
--- a/pandas/io/tests/test_yahoo.py
11+
+++ b/pandas/io/tests/test_yahoo.py
12+
@@ -7,13 +7,15 @@ import re
13+
import unittest
14+
import pandas.io.data as pd
15+
import nose
16+
+from pandas.util.testing import network
17+
18+
class TestYahoo(unittest.TestCase):
19+
20+
+ @network
21+
def test_yahoo(self):
22+
- """asserts that yahoo is minimally working and that it throws
23+
- an excecption when DataReader can't get a 200 response from
24+
- yahoo """
25+
+ # asserts that yahoo is minimally working and that it throws
26+
+ # an excecption when DataReader can't get a 200 response from
27+
+ # yahoo
28+
start = datetime(2010,1,1)
29+
end = datetime(2012,1,24)
30+
self.assertEquals(

0 commit comments

Comments
 (0)