Skip to content
This repository was archived by the owner on Oct 27, 2022. It is now read-only.

Commit 31c7dda

Browse files
fenrus75clrpackages
authored andcommitted
[update to 46.0.0] Add info message when authentication error encountered processing package index.
Andrew Taylor (1): Add info message when authentication error encountered processing package index. Bastian Venthur (5): Deprecated Eggsecutable Scripts Put deprecation in section rather then removing it (updated changelog as well) Added test for DeprecationWarning warning -> deprecated Removed unused context.quiet Dan Rose (1): Remove sys.modules hack Jason R. Coombs (29): Error on warnings. Fixes #1823. Move the error directive to the top, as it's more permanent. Add changelog entry normalize indentation Remove the Features feature. Fixes #65. Update changelog. Add azure pipelines from jaraco/skeleton Bootstrap the environment in tox, allowing simple 'tox' to run tests and simplifying all of the pipelines. Update deprecation version and include extension on changelog file. Avoid installing setuptools 45 on Python 2. Pin virtualenv to <20 as workaround for #1998. Suppress failures due to unfortunate combination of issues. Ref #2000. Copy docs requirements to a separate file due to RTD constraints. Fixes #2001. Ref readthedocs/readthedocs.org#6662 Bump version: 45.2.0 → 45.3.0 Also remove mysterious hack from pkg_resources.extern Try building docs with python3. Ref #1992. Reword UserWarning for insecure extraction path so that the message can be keyed for ignoring it. Ref #1899. Suppress UserWarning in pkg_resources. Try installing pip Use pep517 to avoid bb://pypa/distlib#136. Emit the Python version Add a file 'runtime.txt' to let Netlify know to use that env. Fixes #1992. Docs land in build/html Add a note about runtime.txt Suppress RuntimeWarning from sandbox module on Python 2 Suppress Windows bytes API warning until it can be fixed. Ref #2016. Suppress another warning Get both UnicodeWarnings Bump version: 45.3.0 → 46.0.0 Miro Hrončok (1): Include pkg_resources test data in sdist Ye-hyoung Kang (2): Fix broken link to Python docs Create 2011.doc.rst mayeut (1): Use CPython 3.8.0 mechanism to find msvc 14+
1 parent 1b39954 commit 31c7dda

File tree

7 files changed

+20
-104
lines changed

7 files changed

+20
-104
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := setuptools
2-
URL = https://files.pythonhosted.org/packages/68/75/d1d7b7340b9eb6e0388bf95729e63c410b381eb71fe8875cdfd949d8f9ce/setuptools-45.2.0.zip
2+
URL = https://files.pythonhosted.org/packages/df/ed/bea598a87a8f7e21ac5bbf464102077c7102557c07db9ff4e207bd9f7806/setuptools-46.0.0.zip
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+2-1
Original file line numberDiff line numberDiff line change
@@ -1,9 +1,10 @@
11
[package]
22
name = setuptools
3-
url = https://files.pythonhosted.org/packages/68/75/d1d7b7340b9eb6e0388bf95729e63c410b381eb71fe8875cdfd949d8f9ce/setuptools-45.2.0.zip
3+
url = https://files.pythonhosted.org/packages/df/ed/bea598a87a8f7e21ac5bbf464102077c7102557c07db9ff4e207bd9f7806/setuptools-46.0.0.zip
44
archives =
55
giturl = https://github.com/pypa/setuptools.git
66
domain =
7+
alias =
78

89
[autospec]
910
# build 32 bit libraries

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
161
1+
162

setuptools.spec

+9-58
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : setuptools
6-
Version : 45.2.0
7-
Release : 161
8-
URL : https://files.pythonhosted.org/packages/68/75/d1d7b7340b9eb6e0388bf95729e63c410b381eb71fe8875cdfd949d8f9ce/setuptools-45.2.0.zip
9-
Source0 : https://files.pythonhosted.org/packages/68/75/d1d7b7340b9eb6e0388bf95729e63c410b381eb71fe8875cdfd949d8f9ce/setuptools-45.2.0.zip
6+
Version : 46.0.0
7+
Release : 162
8+
URL : https://files.pythonhosted.org/packages/df/ed/bea598a87a8f7e21ac5bbf464102077c7102557c07db9ff4e207bd9f7806/setuptools-46.0.0.zip
9+
Source0 : https://files.pythonhosted.org/packages/df/ed/bea598a87a8f7e21ac5bbf464102077c7102557c07db9ff4e207bd9f7806/setuptools-46.0.0.zip
1010
Summary : Easily download, build, install, upgrade, and uninstall Python packages
1111
Group : Development/Tools
1212
License : MIT Python-2.0 ZPL-2.0
@@ -21,56 +21,7 @@ BuildRequires : setuptools
2121

2222
%description
2323
.. image:: https://img.shields.io/pypi/v/setuptools.svg
24-
:target: https://pypi.org/project/setuptools
25-
26-
.. image:: https://img.shields.io/readthedocs/setuptools/latest.svg
27-
:target: https://setuptools.readthedocs.io
28-
29-
.. image:: https://img.shields.io/travis/pypa/setuptools/master.svg?label=Linux%20CI&logo=travis&logoColor=white
30-
:target: https://travis-ci.org/pypa/setuptools
31-
32-
.. image:: https://img.shields.io/appveyor/ci/pypa/setuptools/master.svg?label=Windows%20CI&logo=appveyor&logoColor=white
33-
:target: https://ci.appveyor.com/project/pypa/setuptools/branch/master
34-
35-
.. image:: https://img.shields.io/codecov/c/github/pypa/setuptools/master.svg?logo=codecov&logoColor=white
36-
:target: https://codecov.io/gh/pypa/setuptools
37-
38-
.. image:: https://tidelift.com/badges/github/pypa/setuptools?style=flat
39-
:target: https://tidelift.com/subscription/pkg/pypi-setuptools?utm_source=pypi-setuptools&utm_medium=readme
40-
41-
.. image:: https://img.shields.io/pypi/pyversions/setuptools.svg
42-
43-
See the `Installation Instructions
44-
<https://packaging.python.org/installing/>`_ in the Python Packaging
45-
User's Guide for instructions on installing, upgrading, and uninstalling
46-
Setuptools.
47-
48-
Questions and comments should be directed to the `distutils-sig
49-
mailing list <http://mail.python.org/pipermail/distutils-sig/>`_.
50-
Bug reports and especially tested patches may be
51-
submitted directly to the `bug tracker
52-
<https://github.com/pypa/setuptools/issues>`_.
53-
54-
To report a security vulnerability, please use the
55-
`Tidelift security contact <https://tidelift.com/security>`_.
56-
Tidelift will coordinate the fix and disclosure.
57-
58-
59-
For Enterprise
60-
==============
61-
62-
Available as part of the Tidelift Subscription.
63-
64-
Setuptools and the maintainers of thousands of other packages are working with Tidelift to deliver one enterprise subscription that covers all of the open source you use.
65-
66-
`Learn more <https://tidelift.com/subscription/pkg/pypi-setuptools?utm_source=pypi-setuptools&utm_medium=referral&utm_campaign=github>`_.
67-
68-
Code of Conduct
69-
===============
70-
71-
Everyone interacting in the setuptools project's codebases, issue trackers,
72-
chat rooms, and mailing lists is expected to follow the
73-
`PyPA Code of Conduct <https://www.pypa.io/en/latest/code-of-conduct/>`_.
24+
:target: https://pypi.org/project/setuptools
7425

7526
%package bin
7627
Summary: bin components for the setuptools package.
@@ -109,15 +60,15 @@ python3 components for the setuptools package.
10960

11061

11162
%prep
112-
%setup -q -n setuptools-45.2.0
113-
cd %{_builddir}/setuptools-45.2.0
63+
%setup -q -n setuptools-46.0.0
64+
cd %{_builddir}/setuptools-46.0.0
11465

11566
%build
11667
export http_proxy=http://127.0.0.1:9/
11768
export https_proxy=http://127.0.0.1:9/
11869
export no_proxy=localhost,127.0.0.1,0.0.0.0
11970
export LANG=C.UTF-8
120-
export SOURCE_DATE_EPOCH=1582922976
71+
export SOURCE_DATE_EPOCH=1583773223
12172
# -Werror is for werrorists
12273
export GCC_IGNORE_WERROR=1
12374
export AR=gcc-ar
@@ -134,7 +85,7 @@ python3 setup.py build
13485
export MAKEFLAGS=%{?_smp_mflags}
13586
rm -rf %{buildroot}
13687
mkdir -p %{buildroot}/usr/share/package-licenses/setuptools
137-
cp %{_builddir}/setuptools-45.2.0/LICENSE %{buildroot}/usr/share/package-licenses/setuptools/a5234543d56e03c950c0080826b53a0cb97671af
88+
cp %{_builddir}/setuptools-46.0.0/LICENSE %{buildroot}/usr/share/package-licenses/setuptools/a5234543d56e03c950c0080826b53a0cb97671af
13889
python3 -tt setup.py build install --root=%{buildroot}
13990
echo ----[ mark ]----
14091
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
7cef5bf90ea21eed7cad3ca19f4786286ca35d0a/setuptools-45.2.0.zip
1+
7698a119bbfd02602f037d502763400649ce7394/setuptools-46.0.0.zip

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
45.2.0
1+
46.0.0

whatrequires

+5-41
Original file line numberDiff line numberDiff line change
@@ -1,9 +1,6 @@
11
# This file contains recursive sources that require this package
22
Markdown
33
Sphinx
4-
XStatic-Angular
5-
XStatic-Angular-Bootstrap
6-
XStatic-Angular-Gettext
74
aiohttp-cors
85
apache-zookeeper
96
apipkg
@@ -26,85 +23,51 @@ conda
2623
cotyledon
2724
diff-match-patch
2825
distributed
29-
fixtures
3026
flake8-blind-except
3127
flake8-import-order
32-
flake8-polyfill
3328
funcsigs
3429
google-auth
35-
grpc
3630
hgtools
37-
httpretty
38-
ipaddr
3931
ipdb
4032
ipython
41-
ipython-sql
42-
iso8601
33+
jaraco.classes
34+
jaraco.collections
35+
jaraco.text
4336
jarn.viewdoc
4437
josepy
45-
jsonpointer
4638
jsonschema
47-
jupyter-notebook-gist
4839
keyring
4940
keystone
5041
kiwisolver
5142
lazy-object-proxy
5243
librealsense
5344
logilab-common
54-
logutils
55-
mccabe
5645
mercurial
57-
mongodict
58-
monotonic
59-
mox
6046
mozjs
6147
mozjs52
6248
mozjs60
6349
munch
64-
ndg_httpsclient
65-
netaddr
66-
nose-cov
67-
nose-cover3
68-
nose-parameterized
6950
nova
7051
numba
7152
opcodes
7253
openstack-setuptools
7354
oset
74-
pandocfilters
75-
pika-pool
55+
performance
7656
pip-legacy
77-
positional
78-
posix_ipc
79-
pretend
8057
protobuf
81-
ptyprocess
8258
pulsectl
83-
pyScss
84-
pyaml
85-
pydotplus
8659
pypandoc
8760
pyroma
8861
pytest
8962
pytest-rerunfailures
9063
python-Levenshtein
91-
python-augeas
92-
python-ceilometerclient
9364
python-dateutil
94-
python-mimeparse
95-
python-polib
96-
python-systemd
9765
pytorch
98-
pyudev
9966
qtwebengine
100-
rcssmin
10167
repoze.sphinx.autointerface
10268
repoze.who
103-
requestsexceptions
10469
rosdistro
105-
rsa
10670
scikit-build
107-
scripttest
10871
semantic_version
10972
setuptools
11073
setuptools-legacy
@@ -116,6 +79,7 @@ tensorflow-estimator
11679
tensorflow-probability
11780
tensorflow-serving
11881
tldextract
82+
twine
11983
unicodecsv
12084
urllib3
12185
vcstool

0 commit comments

Comments
 (0)