Skip to content

Commit 832c4d6

Browse files
committed
pypi-zipp: Autospec creation for update from version 3.8.1 to version 3.9.0
Jason R. Coombs (19): Use '-dev' for every Python version. Ref actions/setup-python#213. Use Python 3.11 for cutting releases. Pin flake8. Workaround for tholo/pytest-flake8#87. Update to setup-python v4. Fixes jaraco/skeleton#65. Also update release to v4 Add PyPy to the test matrix on Linux. Fixes jaraco/skeleton#63. When rendering docs, preserve the syntax for defaults. Fixes jaraco/path#197. Adopt furo theme for docs. Indicate to use latest Python version (workaround for readthedocs/readthedocs.org/#9623). Requires also specifying the OS version (workaround for readthedocs/readthedocs.org#9635). Test assertions directly ⚫ Fade to black. Fix long line Declare a type of 'type' for class_; addressing mypy failure. Create a mix-in for InitializedState Update tests to use existing files on disk. Fixes failing tests. Implement a more generalized parameterization function and use it for alpharep. Consolidate pickle tests into a single, parameterized test. Update changelog No need to construct a dict for the state. Parker Hancock (2): create lazy loading lookup class to support pickling memoized form of pickling utility class and improved tests
1 parent cd9a5a5 commit 832c4d6

File tree

6 files changed

+14
-14
lines changed

6 files changed

+14
-14
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-zipp
2-
URL = https://files.pythonhosted.org/packages/3b/e3/fb79a1ea5f3a7e9745f688855d3c673f2ef7921639a380ec76f7d4d83a85/zipp-3.8.1.tar.gz
2+
URL = https://files.pythonhosted.org/packages/41/2e/1341c5634c25e7254df01ec1f6cbd2bcdee3e647709e7c3647d1b362e3ac/zipp-3.9.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-zipp
3-
url = https://files.pythonhosted.org/packages/3b/e3/fb79a1ea5f3a7e9745f688855d3c673f2ef7921639a380ec76f7d4d83a85/zipp-3.8.1.tar.gz
3+
url = https://files.pythonhosted.org/packages/41/2e/1341c5634c25e7254df01ec1f6cbd2bcdee3e647709e7c3647d1b362e3ac/zipp-3.9.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/zipp/
66
domain =

pypi-zipp.spec

+9-9
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-zipp
6-
Version : 3.8.1
7-
Release : 50
8-
URL : https://files.pythonhosted.org/packages/3b/e3/fb79a1ea5f3a7e9745f688855d3c673f2ef7921639a380ec76f7d4d83a85/zipp-3.8.1.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/3b/e3/fb79a1ea5f3a7e9745f688855d3c673f2ef7921639a380ec76f7d4d83a85/zipp-3.8.1.tar.gz
6+
Version : 3.9.0
7+
Release : 51
8+
URL : https://files.pythonhosted.org/packages/41/2e/1341c5634c25e7254df01ec1f6cbd2bcdee3e647709e7c3647d1b362e3ac/zipp-3.9.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/41/2e/1341c5634c25e7254df01ec1f6cbd2bcdee3e647709e7c3647d1b362e3ac/zipp-3.9.0.tar.gz
1010
Summary : Backport of pathlib-compatible object wrapper for zip files
1111
Group : Development/Tools
1212
License : MIT
@@ -56,18 +56,18 @@ python3 components for the pypi-zipp package.
5656

5757

5858
%prep
59-
%setup -q -n zipp-3.8.1
60-
cd %{_builddir}/zipp-3.8.1
59+
%setup -q -n zipp-3.9.0
60+
cd %{_builddir}/zipp-3.9.0
6161
pushd ..
62-
cp -a zipp-3.8.1 buildavx2
62+
cp -a zipp-3.9.0 buildavx2
6363
popd
6464

6565
%build
6666
export http_proxy=http://127.0.0.1:9/
6767
export https_proxy=http://127.0.0.1:9/
6868
export no_proxy=localhost,127.0.0.1,0.0.0.0
6969
export LANG=C.UTF-8
70-
export SOURCE_DATE_EPOCH=1657660531
70+
export SOURCE_DATE_EPOCH=1665420710
7171
export GCC_IGNORE_WERROR=1
7272
export AR=gcc-ar
7373
export RANLIB=gcc-ranlib
@@ -92,7 +92,7 @@ popd
9292
export MAKEFLAGS=%{?_smp_mflags}
9393
rm -rf %{buildroot}
9494
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-zipp
95-
cp %{_builddir}/zipp-3.8.1/LICENSE %{buildroot}/usr/share/package-licenses/pypi-zipp/8e6689d37f82d5617b7f7f7232c94024d41066d1
95+
cp %{_builddir}/zipp-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-zipp/8e6689d37f82d5617b7f7f7232c94024d41066d1 || :
9696
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
9797
echo ----[ mark ]----
9898
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
50
1+
51

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
d1f0f48211895d475e9505a73d6282bf9098113d/zipp-3.8.1.tar.gz
1+
8ce743d9a8850db38b52c318087dbe4a2a9868d3/zipp-3.9.0.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
3.8.1
1+
3.9.0

0 commit comments

Comments
 (0)