Skip to content

Commit a988c32

Browse files
committed
pypi-keyring: Autospec creation for update from version 23.9.3 to version 23.11.0
Christoph Reiter (1): libsecret: skip if there is no secret service running Jason R. Coombs (7): Add PyPy to the test matrix on Linux. Fixes jaraco/skeleton#63. When rendering docs, preserve the syntax for defaults. Fixes jaraco/path#197. Adopt furo theme for docs. Indicate to use latest Python version (workaround for readthedocs/readthedocs.org/#9623). Requires also specifying the OS version (workaround for readthedocs/readthedocs.org#9635). Bump requirement on importlib_metadata to 4.11.4. Fixes #526. Disable flake8 due to incompatibility. Update changelog Matěj Cepl (1): Fix typo
1 parent d818087 commit a988c32

File tree

6 files changed

+18
-15
lines changed

6 files changed

+18
-15
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-keyring
2-
URL = https://files.pythonhosted.org/packages/2a/ef/28d3d5428108111dae4304a2ebec80d113aea9e78c939e25255425d486ff/keyring-23.9.3.tar.gz
2+
URL = https://files.pythonhosted.org/packages/1c/35/c22960f14f5e17384296b2f09da259f8b5244fb3831eccec71cf948a49c6/keyring-23.11.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+3-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-keyring
3-
url = https://files.pythonhosted.org/packages/2a/ef/28d3d5428108111dae4304a2ebec80d113aea9e78c939e25255425d486ff/keyring-23.9.3.tar.gz
3+
url = https://files.pythonhosted.org/packages/1c/35/c22960f14f5e17384296b2f09da259f8b5244fb3831eccec71cf948a49c6/keyring-23.11.0.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/keyring/
66
domain =
@@ -35,6 +35,8 @@ insecure_build = false
3535
keepstatic = false
3636
# do not require autostart subpackage
3737
no_autostart = false
38+
# do not use the replacement pattern for file matching
39+
no_glob = false
3840
# do not generate debuginfo for this package
3941
nodebug = false
4042
# disable stripping binaries

pypi-keyring.spec

+11-10
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-keyring
6-
Version : 23.9.3
7-
Release : 130
8-
URL : https://files.pythonhosted.org/packages/2a/ef/28d3d5428108111dae4304a2ebec80d113aea9e78c939e25255425d486ff/keyring-23.9.3.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/2a/ef/28d3d5428108111dae4304a2ebec80d113aea9e78c939e25255425d486ff/keyring-23.9.3.tar.gz
6+
Version : 23.11.0
7+
Release : 131
8+
URL : https://files.pythonhosted.org/packages/1c/35/c22960f14f5e17384296b2f09da259f8b5244fb3831eccec71cf948a49c6/keyring-23.11.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/1c/35/c22960f14f5e17384296b2f09da259f8b5244fb3831eccec71cf948a49c6/keyring-23.11.0.tar.gz
1010
Summary : Store and access your passwords safely.
1111
Group : Development/Tools
1212
License : MIT Python-2.0
@@ -59,6 +59,7 @@ Summary: python3 components for the pypi-keyring package.
5959
Group: Default
6060
Requires: python3-core
6161
Provides: pypi(keyring)
62+
Requires: pypi(importlib_metadata)
6263
Requires: pypi(jaraco.classes)
6364
Requires: pypi(jeepney)
6465
Requires: pypi(secretstorage)
@@ -68,18 +69,18 @@ python3 components for the pypi-keyring package.
6869

6970

7071
%prep
71-
%setup -q -n keyring-23.9.3
72-
cd %{_builddir}/keyring-23.9.3
72+
%setup -q -n keyring-23.11.0
73+
cd %{_builddir}/keyring-23.11.0
7374
pushd ..
74-
cp -a keyring-23.9.3 buildavx2
75+
cp -a keyring-23.11.0 buildavx2
7576
popd
7677

7778
%build
7879
export http_proxy=http://127.0.0.1:9/
7980
export https_proxy=http://127.0.0.1:9/
8081
export no_proxy=localhost,127.0.0.1,0.0.0.0
8182
export LANG=C.UTF-8
82-
export SOURCE_DATE_EPOCH=1663600709
83+
export SOURCE_DATE_EPOCH=1667843649
8384
export GCC_IGNORE_WERROR=1
8485
export AR=gcc-ar
8586
export RANLIB=gcc-ranlib
@@ -91,8 +92,8 @@ export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
9192
export MAKEFLAGS=%{?_smp_mflags}
9293
python3 -m build --wheel --skip-dependency-check --no-isolation
9394
pushd ../buildavx2/
94-
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx"
95-
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx "
95+
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
96+
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
9697
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
9798
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
9899
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
130
1+
131

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
840f129b4df01e19cbfffeb9ff0870eb6a243354/keyring-23.9.3.tar.gz
1+
be5891faa368caba2e9c7dd92080df3aa291f221/keyring-23.11.0.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
23.9.3
1+
23.11.0

0 commit comments

Comments
 (0)