Skip to content

Commit 5b873fc

Browse files
committed
pypi-jaraco.functools: Autospec creation for update from version 3.5.0 to version 3.5.1
Anderson Bravalheri (2): Ignore flake8/black warnings with pytest 7.0.1 (jaraco/skeleton#58) Update Github actions to v3 (#62) Hugo van Kemenade (1): Update base URL for PEPs (#61) Jason R. Coombs (28): Add Tidelift template Rely on alabaster theme to support sidebar rendering. Use nicer, simpler phrasing Add support for automatic publishing of release notes Use technique for environment passing matching that found in jaraco/skeleton Move Tidelift token into Travis configuration Update badge URL Add funding reference to project List sidebars to avoid errors looking for template 't' Rebrand to 'For Enterprise' Add a 'For Enterprise' section to the README Include token passthrough for azure pipelines publish stage. Move Tidelift release note publishing to Github Actions. Tidelift no longer requires or expects publishing release notes. Remove Tidelift from main.yml, no longer needed Implement tidelift banner using a Sphinx directive implemented by jaraco.tidelift. Update badge year Remove setup.py, no longer needed. Add exclusions for pytest 7 deprecations in plugins. Fixes jaraco/skeleton#57. Use the parent category PytestDeprecationWarning, which is available on older pytest versions. Fixes jaraco/skeleton#57. Bump pytest-mypy and remove workaround for realpython/pytest-mypy#131. Require jaraco.packaging 9 adding compatibility for projects with no setup.py file. Ran pre-commit autoupdate Add Python 3.11 into the matrix using workaround from actions/setup-python#213. Drop 3.9 from matrix for efficiency. Prefer spaces for rst. Fixes jaraco/skeleton#64. Honor PEP 518 with pytest-enabler. Ran pre-commit autoupdate Update changelog. Sviatoslav Sydorenko (1): Inject check job into CI workflow as ultimate flag (#55) wim glenn (1): exclude build env from cov reporting (#60)
1 parent 92cc8c3 commit 5b873fc

File tree

6 files changed

+14
-14
lines changed

6 files changed

+14
-14
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-jaraco.functools
2-
URL = https://files.pythonhosted.org/packages/1e/c8/6733dc1c6afca663c08534e7f4e7b14751019f6dd3476c40dbecb3904449/jaraco.functools-3.5.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/e2/61/12a154326f2d4f403193fb207aa867b4e1ce6ccdfa0b425ab4a25873b39e/jaraco.functools-3.5.1.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-jaraco.functools
3-
url = https://files.pythonhosted.org/packages/1e/c8/6733dc1c6afca663c08534e7f4e7b14751019f6dd3476c40dbecb3904449/jaraco.functools-3.5.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/e2/61/12a154326f2d4f403193fb207aa867b4e1ce6ccdfa0b425ab4a25873b39e/jaraco.functools-3.5.1.tar.gz
44
archives =
55
giturl = https://github.com/jaraco/jaraco.functools/
66
domain =

pypi-jaraco.functools.spec

+9-9
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-jaraco.functools
6-
Version : 3.5.0
7-
Release : 41
8-
URL : https://files.pythonhosted.org/packages/1e/c8/6733dc1c6afca663c08534e7f4e7b14751019f6dd3476c40dbecb3904449/jaraco.functools-3.5.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/1e/c8/6733dc1c6afca663c08534e7f4e7b14751019f6dd3476c40dbecb3904449/jaraco.functools-3.5.0.tar.gz
6+
Version : 3.5.1
7+
Release : 42
8+
URL : https://files.pythonhosted.org/packages/e2/61/12a154326f2d4f403193fb207aa867b4e1ce6ccdfa0b425ab4a25873b39e/jaraco.functools-3.5.1.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/e2/61/12a154326f2d4f403193fb207aa867b4e1ce6ccdfa0b425ab4a25873b39e/jaraco.functools-3.5.1.tar.gz
1010
Summary : Functools like those found in stdlib
1111
Group : Development/Tools
1212
License : MIT
@@ -56,18 +56,18 @@ python3 components for the pypi-jaraco.functools package.
5656

5757

5858
%prep
59-
%setup -q -n jaraco.functools-3.5.0
60-
cd %{_builddir}/jaraco.functools-3.5.0
59+
%setup -q -n jaraco.functools-3.5.1
60+
cd %{_builddir}/jaraco.functools-3.5.1
6161
pushd ..
62-
cp -a jaraco.functools-3.5.0 buildavx2
62+
cp -a jaraco.functools-3.5.1 buildavx2
6363
popd
6464

6565
%build
6666
export http_proxy=http://127.0.0.1:9/
6767
export https_proxy=http://127.0.0.1:9/
6868
export no_proxy=localhost,127.0.0.1,0.0.0.0
6969
export LANG=C.UTF-8
70-
export SOURCE_DATE_EPOCH=1656398768
70+
export SOURCE_DATE_EPOCH=1657810238
7171
export GCC_IGNORE_WERROR=1
7272
export CFLAGS="$CFLAGS -fno-lto "
7373
export FCFLAGS="$FFLAGS -fno-lto "
@@ -89,7 +89,7 @@ popd
8989
export MAKEFLAGS=%{?_smp_mflags}
9090
rm -rf %{buildroot}
9191
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools
92-
cp %{_builddir}/jaraco.functools-3.5.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools/8e6689d37f82d5617b7f7f7232c94024d41066d1
92+
cp %{_builddir}/jaraco.functools-3.5.1/LICENSE %{buildroot}/usr/share/package-licenses/pypi-jaraco.functools/8e6689d37f82d5617b7f7f7232c94024d41066d1
9393
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
9494
echo ----[ mark ]----
9595
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
41
1+
42

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
3a2b3f8d538c3dcbf71d7cc1365cc7536df34dd0/jaraco.functools-3.5.0.tar.gz
1+
7666ba434d081a059c916109439cdc630c7de4b1/jaraco.functools-3.5.1.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
3.5.0
1+
3.5.1

0 commit comments

Comments
 (0)