Skip to content

Commit fef8ffa

Browse files
committed
pypi-importlib_resources: Autospec creation for update from version 5.9.0 to version 5.10.0
Jason R. Coombs (27): Inline type defintions Implement resolve as a single-dispatch function. (#261) Use '-dev' for every Python version. Ref actions/setup-python#213. Use Python 3.11 for cutting releases. Pin flake8. Workaround for tholo/pytest-flake8#87. Update to setup-python v4. Fixes jaraco/skeleton#65. Also update release to v4 Add PyPy to the test matrix on Linux. Fixes jaraco/skeleton#63. When rendering docs, preserve the syntax for defaults. Fixes jaraco/path#197. Adopt furo theme for docs. Indicate to use latest Python version (workaround for readthedocs/readthedocs.org/#9623). Requires also specifying the OS version (workaround for readthedocs/readthedocs.org#9635). Add test capturing current behavior and missed expectation. Ref #203. Remove restriction that a 'package' cannot be a module. Allows resolution of resources from adjacent modules, even those not found in a package. Fixes #203. Update changelog. Ref #203. Update docs to prefer the name 'anchor' to 'package', as the anchor may be a module. Rewrite section using imperative voice and add determiners. Remove docs pertinent to Python 3.6 and earlier. Extend type spec for clarity. Use more namespaces. Prefer relative imports for abc. Correct the changelog to mention the correct function affected. Rename the 'package' parameter to 'anchor'. Add doctests to flesh out coverage. Add test capturing expectation. Extract fixture for SiteDir. Implement caller inference to allow ``files()`` to be called without any parameter. Update changelog sobolevn (1): Replace `abstractproperty` with `property` + `abstractmethod`
1 parent b2cd8ac commit fef8ffa

File tree

6 files changed

+14
-14
lines changed

6 files changed

+14
-14
lines changed

Makefile

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,5 +1,5 @@
11
PKG_NAME := pypi-importlib_resources
2-
URL = https://files.pythonhosted.org/packages/38/b6/bc58f9261c70abb5fd670f9ad5d84445a402b4b473f308c5bf699cd379e0/importlib_resources-5.9.0.tar.gz
2+
URL = https://files.pythonhosted.org/packages/06/72/6bf0df4fe7a139147f5d6b473f16d5aefb7bc5b719ba5dd33f230d35760f/importlib_resources-5.10.0.tar.gz
33
ARCHIVES =
44

55
include ../common/Makefile.common

options.conf

+1-1
Original file line numberDiff line numberDiff line change
@@ -1,6 +1,6 @@
11
[package]
22
name = pypi-importlib_resources
3-
url = https://files.pythonhosted.org/packages/38/b6/bc58f9261c70abb5fd670f9ad5d84445a402b4b473f308c5bf699cd379e0/importlib_resources-5.9.0.tar.gz
3+
url = https://files.pythonhosted.org/packages/06/72/6bf0df4fe7a139147f5d6b473f16d5aefb7bc5b719ba5dd33f230d35760f/importlib_resources-5.10.0.tar.gz
44
archives =
55
giturl = https://github.com/python/importlib_resources/
66
domain =

pypi-importlib_resources.spec

+9-9
Original file line numberDiff line numberDiff line change
@@ -3,10 +3,10 @@
33
# Generated by: autospec.py
44
#
55
Name : pypi-importlib_resources
6-
Version : 5.9.0
7-
Release : 23
8-
URL : https://files.pythonhosted.org/packages/38/b6/bc58f9261c70abb5fd670f9ad5d84445a402b4b473f308c5bf699cd379e0/importlib_resources-5.9.0.tar.gz
9-
Source0 : https://files.pythonhosted.org/packages/38/b6/bc58f9261c70abb5fd670f9ad5d84445a402b4b473f308c5bf699cd379e0/importlib_resources-5.9.0.tar.gz
6+
Version : 5.10.0
7+
Release : 24
8+
URL : https://files.pythonhosted.org/packages/06/72/6bf0df4fe7a139147f5d6b473f16d5aefb7bc5b719ba5dd33f230d35760f/importlib_resources-5.10.0.tar.gz
9+
Source0 : https://files.pythonhosted.org/packages/06/72/6bf0df4fe7a139147f5d6b473f16d5aefb7bc5b719ba5dd33f230d35760f/importlib_resources-5.10.0.tar.gz
1010
Summary : Read resources from Python packages
1111
Group : Development/Tools
1212
License : Apache-2.0
@@ -54,18 +54,18 @@ python3 components for the pypi-importlib_resources package.
5454

5555

5656
%prep
57-
%setup -q -n importlib_resources-5.9.0
58-
cd %{_builddir}/importlib_resources-5.9.0
57+
%setup -q -n importlib_resources-5.10.0
58+
cd %{_builddir}/importlib_resources-5.10.0
5959
pushd ..
60-
cp -a importlib_resources-5.9.0 buildavx2
60+
cp -a importlib_resources-5.10.0 buildavx2
6161
popd
6262

6363
%build
6464
export http_proxy=http://127.0.0.1:9/
6565
export https_proxy=http://127.0.0.1:9/
6666
export no_proxy=localhost,127.0.0.1,0.0.0.0
6767
export LANG=C.UTF-8
68-
export SOURCE_DATE_EPOCH=1658764372
68+
export SOURCE_DATE_EPOCH=1665419158
6969
export GCC_IGNORE_WERROR=1
7070
export AR=gcc-ar
7171
export RANLIB=gcc-ranlib
@@ -90,7 +90,7 @@ popd
9090
export MAKEFLAGS=%{?_smp_mflags}
9191
rm -rf %{buildroot}
9292
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-importlib_resources
93-
cp %{_builddir}/importlib_resources-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-importlib_resources/2b8b815229aa8a61e483fb4ba0588b8b6c491890
93+
cp %{_builddir}/importlib_resources-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-importlib_resources/2b8b815229aa8a61e483fb4ba0588b8b6c491890 || :
9494
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
9595
echo ----[ mark ]----
9696
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :

release

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
23
1+
24

upstream

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
3b4b20fa0399e2fa21c7506be27a4b943495d3ad/importlib_resources-5.9.0.tar.gz
1+
a8c7a6a976fffb9841c548230cb633eda3111c4f/importlib_resources-5.10.0.tar.gz

versions

+1-1
Original file line numberDiff line numberDiff line change
@@ -1 +1 @@
1-
5.9.0
1+
5.10.0

0 commit comments

Comments
 (0)