Skip to content
This repository was archived by the owner on Mar 31, 2025. It is now read-only.

Commit 27469be

Browse files
fix(generateComponentGroup processor): ensure doc has a name
Fixes angular/angular.js#8860
1 parent 67ea0c2 commit 27469be

File tree

2 files changed

+2
-0
lines changed

2 files changed

+2
-0
lines changed

ngdoc/processors/generateComponentGroups.js

+1
Original file line numberDiff line numberDiff line change
@@ -27,6 +27,7 @@ module.exports = function generateComponentGroupsProcessor(moduleMap) {
2727
moduleName: module.name,
2828
moduleDoc: module,
2929
area: module.area,
30+
name: docType + ' components in ' + module.name,
3031
components: docs
3132
};
3233
})

ngdoc/spec/processors/generateComponentGroups.spec.js

+1
Original file line numberDiff line numberDiff line change
@@ -25,6 +25,7 @@ describe("generateComponentGroupsProcessor", function() {
2525

2626
expect(docs.length).toEqual(2);
2727

28+
expect(docs[0].name).toEqual('a components in mod1');
2829
expect(docs[0].moduleName).toEqual('mod1');
2930
expect(docs[0].moduleDoc).toEqual(jasmine.objectContaining({ id: 'mod1' }));
3031
});

0 commit comments

Comments
 (0)