Skip to content
This repository was archived by the owner on Mar 31, 2025. It is now read-only.

Commit 076634d

Browse files
fix(generateComponentGroup processor): ensure doc has a name
Fixes angular/angular.js#8860
1 parent 787afee commit 076634d

File tree

2 files changed

+3
-0
lines changed

2 files changed

+3
-0
lines changed

ngdoc/processors/component-groups-generate.js

+1
Original file line numberDiff line numberDiff line change
@@ -30,6 +30,7 @@ module.exports = {
3030
return {
3131
id: module.id + '.' + docType,
3232
docType: 'componentGroup',
33+
name: docType + ' components in ' + module.id,
3334
groupType: docType,
3435
module: module.name,
3536
moduleDoc: module,

ngdoc/spec/processors/component-groups-generate.spec.js

+2
Original file line numberDiff line numberDiff line change
@@ -23,6 +23,8 @@ describe("component-groups processor", function() {
2323
processor.process(docs, config, modules);
2424

2525
expect(docs.length).toEqual(2);
26+
expect(docs[0].name).toEqual('a components in mod1');
27+
expect(docs[1].name).toEqual('b components in mod1');
2628
});
2729

2830

0 commit comments

Comments
 (0)